Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

IDE newbie question

Altera_Forum
Honored Contributor II
791 Views

Hey yall. Im using NIOS II IDE ,ad I want to use some Altera university IP cores, I follow the PDF that comes with my version of the suite. BUt I get a really weid error. 

 

When I tell it to compile it complains that it cannot find the# include "altera_up_avalon_audio.h" file. It says that the file or folder is inexistant. 

 

But I can browse to i just by using the project explorer on the left. I have tried up and down an option to tell where to look But I think eclipse has beat me to it again. 

 

Here are some screen shots. Please Help I am beating my head on this one for some time. 

regards :)
0 Kudos
2 Replies
Altera_Forum
Honored Contributor II
70 Views

I guess your University_Program folder and subfolders were not added in the syslib include path list. Open syslib properties and try to add manually

Altera_Forum
Honored Contributor II
70 Views

Yes That is exactly what I have tried to do. I have dumped the contents of the university program in there but still I get problems.  

 

I haven't however found the exact instruction of how to properlly tell the compiler to took in those folder... 

 

but as you see on the picture, the files are in the IDE under the Altera.Components tree inside of Eclipse.  

 

Still today no luck. I'm on version 9.2 

Can if you would kindly explain to me how to add the compiler to search inside of those folders for those .h and .C files.  

 

Thanks 

Gabriel
Reply