Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jpk
Beginner
132 Views

Intel FPGA monitor_host connection issue

Jump to solution

Hi!

I am a DE1_SoC user. I am using Quartus prime lite 16.1, and I am working on an Intel FPGA monitor program tutorial. In the project creation stage, an error message appears stating that the cable cannot be found in the "host connection" category. However, the "programming" function of the Quartus prime lite 16.1 normally recognizes JTAG. How to solve this problem. Also, whenever I run an Intel FPGA monitor, it requests "javaw.exe". I'm manually specifying it every time, but I don't know if this is normal. Do you have any experts to solve this problem?

0 Kudos

Accepted Solutions
Blair
Employee
103 Views

Hi,

You shouldn't have to manually specify javaw.exe every time. I assume that you are using Windows. Are you running the monitor program from the Windows shortcut that was created by the installer. If yes, what is the "Target" of that shortcut (ie. what is the shortcut trying to run). It should be something like:  'C:\intelFPGA\16.1\quartus\bin64\jre64\bin\javaw.exe -Dsun.java2d.noddraw=true -jar C:\intelFPGA\16.1\University_Program\Monitor_Program\bin\Altera_Monitor_Program.jar'

 

Kind regards,

Blair

View solution in original post

7 Replies
Blair
Employee
104 Views

Hi,

You shouldn't have to manually specify javaw.exe every time. I assume that you are using Windows. Are you running the monitor program from the Windows shortcut that was created by the installer. If yes, what is the "Target" of that shortcut (ie. what is the shortcut trying to run). It should be something like:  'C:\intelFPGA\16.1\quartus\bin64\jre64\bin\javaw.exe -Dsun.java2d.noddraw=true -jar C:\intelFPGA\16.1\University_Program\Monitor_Program\bin\Altera_Monitor_Program.jar'

 

Kind regards,

Blair

View solution in original post

jpk
Beginner
93 Views

Hi!

Thank you so much! Thanks to this, the problem of running the monitor program was solved. But still, the "host connection" problem is not resolved. I don't know why it doesn't recognize Cable.
Can you help me more about this?

Blair
Employee
79 Views

Hi,

Thank you for the screenshot, it is very helpful. It seems that the monitor program is not getting the correct path for Quartus. It's getting c:/altera/quartus/ isn't quartus installed at c:/intelFPGA_lite/16.1/. Do you have two versions of quartus installed? What path is set in the environment variable 'QUARTUS_ROOTDIR'? I think you might need to fix it.

Kind regards,

Blair

jpk
Beginner
67 Views

Quartus was 16.1 and only one was installed. The monitor program was originally installed to 16.1, but due to the same problem, I upgraded to 18.1. When installing the monitor program, it was installed as it was because the program automatically set it to "c:\altera" in the item asking for the installation path. Today, while installing 16.1 again, I changed it to "C:\intelFPGA_lite" and installed it, but the phenomenon is the same. How do I change the QUARTUS_ROOTDIR setting? Please gave me the detail guide.

jpk_0-1618032700298.png

 

Regards.

Blair
Employee
56 Views

Hi,

A guide to editing environment variables is here: https://www.architectryan.com/2018/08/31/how-to-change-environment-variables-on-windows-10/

 

However, running Quartus should update the environment variable automatically. You can use the steps in the link above to view your environment varaibles to make sure that it is set properly.

Kind regards,

Blair

jpk
Beginner
36 Views

Hi!

 

Thanks to your great support, I could go further more. But Unfortunately, I have another issue to download the code into device. I leave the process message as below. 

I can't understand this error message "Could not query JTAG Instance IDs.
Please ensure the FPGA has been configured using the correct .sof file." 

Can you guide me regarding this.

your guiding has been great help so far.

jpk_0-1618205352501.png

 

----------------------------------------------------------------------------------------------

 

C:/intelFPGA_lite/quartus/bin64/quartus_pgm -c "DE-SoC [USB-1]" --auto
1) DE-SoC [USB-1]
4BA00477 SOCVHPS
02D120DD 5CSE(BA5|MA5)/5CSTFD5D5/..
Internal Error: Sub-system: PGMIO, File: /quartus/pgm/pgmio/pgmio_dev_info_manager.cpp, Line: 492
FIO_FILE_SYSTEM::exists(device_file.fullpath().c_str()) && FIO_FILE_SYSTEM::status(device_file.fullpath().c_str(), &stat_info)
Stack Trace:
0x6e31b: PGMIO_DEV_INFO_MANAGER::initialize_device_database + 0x14b (pgm_pgmio)
0x69c7b: PGMIO_DEV_INFO_MANAGER::PGMIO_DEV_INFO_MANAGER + 0x18b (pgm_pgmio)
0xbc942: PGMIO_DEVICE_MANAGER::pgmio_process_parts_file + 0x222 (pgm_pgmio)
0xa2c7d: PGMIO_DEVICE_MANAGER::PGMIO_DEVICE_MANAGER + 0x21d (pgm_pgmio)
0xb816c: PGM_DEVICE_INDEX::lookup_device + 0xb2c (pgm_pgmio)
0x18c13: QPGM_FRAMEWORK::create_chain + 0x1b3 (quartus_pgm)
0x1f4f7: QPGM_FRAMEWORK::process_operation + 0x7e7 (quartus_pgm)
0x1dd30: QPGM_FRAMEWORK::post_check_arguments + 0x270 (quartus_pgm)
0x15ebd: qexe_run + 0x1ad (comp_qexe)
0x16e51: qexe_standard_main + 0xc1 (comp_qexe)
0x2173d: qpgm_main + 0x9d (quartus_pgm)
0x13328: msg_main_thread + 0x18 (CCL_MSG)
0x14b0e: msg_thread_wrapper + 0x6e (CCL_MSG)
0x15b00: mem_thread_wrapper + 0x70 (ccl_mem)
0x12a11: msg_exe_main + 0xa1 (CCL_MSG)
0x22b3a: __tmainCRTStartup + 0x10e (quartus_pgm)
0x17033: BaseThreadInitThunk + 0x13 (KERNEL32)
0x52650: RtlUserThreadStart + 0x20 (ntdll)

End-trace

Could not query JTAG Instance IDs.
Please ensure the FPGA has been configured using the correct .sof file.

 

jpk
Beginner
29 Views

I just solved my problem.

I was path problem when I install the Quartus program.

It shouldn't set as "C:\intelFPGA_lite\16.1". Install process shouldn't suggest create the "16.1" folder.

It should be just "C:\intelFPGA_lite". 

Anyway, really thank you for your help.

Reply