Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Honored Contributor I
776 Views

UPDS Installation Error

I keep getting an error that says "Altera University Program Design Suite requires Nios II to be installed." 

 

I have already installed Quartus II 10.0 and Nios II EDS 10.0 as instructed. I also tried Quartus 9.1 and attempted on multiple computers. 

 

Does anyone know how to fix this?
0 Kudos
11 Replies
Highlighted
Honored Contributor I
25 Views

i think the UPDS only works with the 9.0(sp2) tools. it mentions this somewhere in the documentation or files

0 Kudos
Highlighted
Honored Contributor I
25 Views

Hi, do you know any where that i can find this info?

0 Kudos
Highlighted
Honored Contributor I
25 Views

heh, its a stretch but the URL to the UPDS installer has 9.0 in it

0 Kudos
Highlighted
Honored Contributor I
25 Views

I received the same installation error when trying to install the UPDS with Quartus II Web Edition 10.0 and Nios II EDS 10.0 on Windows XP. 

 

However, I was able to install UPDS after installing Quartus II Web Edition version 9.1sp2 and Nios II EDS 9.1.  

 

After installing the UPDS, I applied the SP1 and SP2 patches to the Nios II EDS. 

 

HTH, 

Rick
0 Kudos
Highlighted
Honored Contributor I
25 Views

Each release of the UPDS requires a specific version of the QII and Nios II installations. It sounds like the version you are using requires Q II 9.0 sp2. To download this version, do to the Download Center on altera.com and look under Archives (on the left side of the page) to find the required version. When you first run the version after installation, it should set the environment variable called QUARTUS _ROOTDIR, which is the variable checked by the UPDS installer.

0 Kudos
Highlighted
Honored Contributor I
25 Views

Is there any resolution here? I am having the same issues - both Quartus and the Nios EDS are 10.0. I need the UPDS for 10.0. The download site shows only 9.0 and 9.1 and I get the same error message about Nios II EDS not being installed.

0 Kudos
Highlighted
Honored Contributor I
25 Views

Try contacting those responsible (http://www.terasic.com.tw/cgi-bin/page/archive.pl?language=english&categoryno=47&no=132) for the UPDS... 

 

Near the bottom of the page you'll see: 

 

 

--- Quote Start ---  

University Program Team: Prof. Stephen Brown, Blair Fort, Mike Phipps, Ralene Marcoccia, and Prof. Zvonko Vranesic 

--- Quote End ---  

 

 

I'd start with the first on the list (http://www.eecg.toronto.edu/~brown/) and work down. I'm sure they'll love to hear from you... 

 

Cheers, 

 

--slacker
0 Kudos
Highlighted
Honored Contributor I
25 Views

apparently we've already heard from the first on the list

0 Kudos
Highlighted
Honored Contributor I
25 Views

You can install the UPDS and use it with version 10.0 or Quartus II and Nios II by manually creating an environment variable. The variable is called SOPC_KIT_NIOS2 and it should point to “c:\altera\10.0\nios2eds” or whatever the nios2eds directory is.

0 Kudos
Highlighted
Honored Contributor I
25 Views

I wrote a little batch file that you can place in the same directory to make this easy: 

 

upds_setup.bat: 

SET SOPC_KIT_NIOS2=c:\altera\10.1\nios2eds START altera_upds_setup_verilog.exe  

 

Obviously, change this if your path is elsewhere, or if you're using VHDL. 

 

Regards, 

Jonathon
0 Kudos
Highlighted
Honored Contributor I
25 Views

Hi everyone, 

I'm just a beginner but I'm having a similar problem trying to install UPDS: 

 

"Altera University Program Design Suite (v11.0) requires Quartus II version 11.0" 

 

I definitely have Quartus II version 11.0 Web Edition installed and I have checked the evironment variables which are as follows: 

 

QUARTUS_ROOTDIR C:\altera\11.0\quartus 

SOPC_KIT_NIOS2 C:\altera\11.0\nios2eds 

 

Would be very grateful for any ideas for what I should do?
0 Kudos