Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
1119 Discussions

Waveform simulation not displaying output.

fpgamodelsim
Beginner
283 Views

I am using ModelSim 19.1 and it intel FPGA. I tried to compile and simulate my program for bit adders and it showed a white blank window with no black simulation graph. I know that I am supposed to get a black window with a blank simulation graph with graphed signal lines for the outputs. Since I could not get the output for the waveform simulation for the adder, and I could not fix the graph by adding a wave, after compiling my program and simulating it, I would encounter an issue that seemed permanent to not solve. I wonder who would know how to fix Intel FPGA ModelSim 19.1 graph problems. I would share my screen of the waveform simulation, and I would show the issue with the waveform simulation display graph, and that it is not displaying the output for the bit-adder. I know that if the waveform simulation graph is fixed, I would be able to simulate any adder or fully designed VHDL component.

0 Kudos
4 Replies
SyafieqS
Moderator
260 Views

Roshaan,


Any snapshot possible?

What OS are you using?

Note: Win 11 is no supported


SyafieqS
Moderator
237 Views

Hi Roshaan,


Assuming I understand you issue correctly, 

You seem cannot see the wave window in modelsim, and you can try to bring up a wave window by selecting "View > Wave" in the ModelSim menu to enable it. You can see more option is view tab. 


 


SyafieqS
Moderator
199 Views

Hi Roshaan,


May I know if there is any update regarding the issue from your end?

Are you able to work on this?



SyafieqS
Moderator
193 Views

We do not receive any response from you to the previous reply that I have provided, thus I will put this case to close pending. Please post a response in the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you with your follow-up questions. 


Reply