Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
1175 Discussions

Which Version of Quartus supports DE10-Standard?

gkankanh
Beginner
940 Views

I have installed the Quartus lite edition 22.X. DE-10 standard board is not listed at all. Downloading the board support files does not work either.

JTAG consistently crashes quartus. 

All help and guidance appreciated.

Labels (1)
0 Kudos
9 Replies
gkankanh
Beginner
931 Views

Screenshot 2023-11-17 100654.png

Screenshot 2023-11-17 101231.png

Screenshot 2023-11-17 101353.png

Problem Details
Error:
Internal Error: Sub-system: PGME, File: /quartus/pgm/pgme/pgme_engine.cpp, Line: 4555
count >= static_cast<DWORD>(device_chain->size())
Stack Trace:
    0x55ee1: PGME_PROGRAMMER::get_device_chain_with_dummy_jtag_bit + 0x161 (pgm_pgme)
    0x3fe8f: PGME_PROGRAMMER::engage + 0x288f (pgm_pgme)
    0x8b715: PGMWQ_PROGRAMMING_THREAD::run + 0x25 (pgm_pgmwq)
    0x2c760: QThread::start + 0x3e0 (Qt5Core)
    0x1257c: BaseThreadInitThunk + 0x1c (KERNEL32)
    0x5aa57: RtlUserThreadStart + 0x27 (ntdll)
 
End-trace
 
Quartus Prime Version 22.1std.2 Build 922 07/20/2023 SC Lite Edition

Executable: quartus
Comment:
None

System Information
Platform: windows64
OS name: Windows 10
OS version: 10.0

Quartus Prime Information
Address bits: 64
Version: 22.1std.2
Build: 922
Edition: Lite Edition
0 Kudos
Elina_Intel
Employee
857 Views

Hi,

 

Thank you for reaching out.

Just to let you know that Intel has received your support request and I am assigned to work on it.


Best Regards,

Elina


0 Kudos
Elina_Intel
Employee
854 Views
0 Kudos
Elina_Intel
Employee
816 Views

Hi,


May i get some update from your issue ?


Thanks


Best Regards,

Elina



0 Kudos
gkankanh
Beginner
807 Views

The document you pointed to needs to be updated. The quartus version mentioned in the doc 16.1 is not available for download from the intel site. That is the reason post.

0 Kudos
_AK6DN_
Valued Contributor I
783 Views

That board was released in 2017 when QuartusII 16.1 was the current version.

Maybe you need to contact TerAsic via https://www.terasic.com.tw/en/

to see what they recommend to use at this time.

0 Kudos
gkankanh
Beginner
775 Views

Thanks. I managed to get it working with quartus lite 22.1. Just want to ensure the docs get updated as long as the board is supported.

Hopefully this will help any new comers as far as required versions,  getting started and so on.

Thanks again.

 

0 Kudos
Elina_Intel
Employee
721 Views

Hi gkankanh,


Shall i close this case ?


Regards,

Elina


0 Kudos
Elina_Intel
Employee
653 Views

Hi,


Will close this case since it resolved already,


Thanks


Best Regard,

Elina


0 Kudos
Reply