Intel® FPGA University Program
University Program Material, Education Boards, and Laboratory Exercises
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.

interrupt problem

Altera_Forum
Honored Contributor II
804 Views

hii help plz, 

 

i want to send a data between the altera de2 to the pc via ethernet port. i was succeed to do it; but i have a problem the de2 can reach to 100Mbps and i can reach just to 10Mbps, after i change the nios and the sdram clock to 100Mhz instead of 50Mhz i was able to reach 20Mbps but it still not good. i guess it Because the interrupt that happen by the clock frequency what can i do?? 

0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
71 Views

Hello BIGBG, 

 

Are you still looking for a solution to this issue ? 

 

Your question is not so clear: Are you talking about baud rates or are you talking about throughput through your Ethernet connection ? 

 

I have a DE2-115 and it is doing Gigabit without a problem. (I hope you do not have a DE2-70) 

 

As far as throughput is concerned: If you use Altera triple speed Ethernet, the majority of the work is done by DMA transfers, if you want high rates i think this is the way to go. 

 

What can limit the speed it the capacity of the switch or even the PC (and its software). 

 

Another theme is are you using UDP or TCP/IP these parameters also have influence on the maximum throughput. 

 

Best Regards, 

Johi.
Reply