Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
28603 Discussions

Error: zeDriverGETExtensionFunctionAddress --> omptarget.rt.level0.dll

CarlSteefel
New Contributor I
428 Views

I get this error message when I launch from the Visual Studio environment

"The procedure entry point zeDriverGETExtensionFunctionAddress could not be located in the dynamic link library
C:\Program Files (x86)\Intel\oneAPI\compiler\2024.1\bin\omptarget.rt.level0.dll."

When I click on this, it continues to run to completion, so at least it is not a "fatal error".

This is on Windows 10 with the latest Intel oneAPI (2024.1) and Visual Studio (2022).

Identical oneAPI and Visual Studio with the same code and same Visual Studio/oneAPI settings (running from the Visual Studio IDE) on Windows 11 does not give the error, so perhaps there is some issue with Windows 10???

Same error from the command line, so cannot blame it on Visual Studio it seems...

0 Kudos
1 Solution
CarlSteefel
New Contributor I
216 Views

I actually don't need or want the GPU, so that was the mistake.  I inherited the settings from somebody else who was trying to offload to GPU, so he had turned on the option: Enable OpenMP offloading".  

 

Once I turned this off, it worked fine.  On Windows 11, it worked even with that setting turned on...

View solution in original post

0 Kudos
3 Replies
CarlSteefel
New Contributor I
427 Views

The possible "clue" I mentioned above does not seem likely, since the Windows 11 that runs without the (non-fatal) error message shows the same warning.

0 Kudos
Xiaoping_D_Intel
Employee
248 Views

For OpenMP program targeted for Intel GPU "Level 0 and OpenCL graphics drivers" are required. Please follow the directions in the article appropriate for your device included in https://www.intel.com/content/www/us/en/developer/articles/system-requirements/oneapi-fortran-compiler-system-requirements.html to install the driver.



0 Kudos
CarlSteefel
New Contributor I
217 Views

I actually don't need or want the GPU, so that was the mistake.  I inherited the settings from somebody else who was trying to offload to GPU, so he had turned on the option: Enable OpenMP offloading".  

 

Once I turned this off, it worked fine.  On Windows 11, it worked even with that setting turned on...

0 Kudos
Reply