Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
154 Views

FORTRAN Compile/linker failure

(1I am running the Intel Fortran complier on a 2020 16-inch MacBook Pro (MacOS Catalina 10,15.7). I just dowloaded your Version 4, which compiles, assembles and runs with old-fashioned input and output files (programs CNDOP (a child of CNINDO and other INDO and CNDO2 codes, written 1980-present) and CELMAP (written and improved by just me  1970-1986).  The third program, EWALD (written by me 1970-present; source code attached) worked well with your compiler up to last year. This third program compiles and loads, but when run, quickly comes up with a fatal error: it wipes out input files (LINPUT, called FOR.07.DAT.tif (attached))  and even wipes out the output file (FOR.06, called LOUTPT), regardless of how I reposition within the program the relative position of reads  (from LINPUT=07) and writes on LOUTPT=06).  The message  I get after the command line "exec desktop/ewald.exe" is \"forrt1: No such fiue or R.p7. directory. fort1:vsevere (29): file not found unit=7, file /Users/robertmetzger/for.07; image ewald.exe ...etc.  Note that FOR.06 is not mentioned. my guess is that this diagnostic output (like the infamous run-time message "OC5" on the IBM 360/67)  is NOT a failure of the file assignment , but rather some weird catch-all phrase for  "compile and assemble error"

I sent EWALD.FOR  and FOR.07.DAT to a colleague in Dresden Germany today: it ran FLAWLESSLY !!! (output is FOR.06.DAT.TXT, attached) Obviously Intel did something to the compiler/linker since last year: what was it? WHAT IS IT? Call me on my cell phone <XXXXXX edited for privacy> day or night. or leave me a message or an e-email <xxxxxx edited for privacy>

(2) "source /opt/intel/bin/compilervars.sh intel64",  when invoked, causes a chorus  of complaints... What is going on?

Help !

Robert Melville Metzger, Prof. of Chemistry, University of Alabama

 

0 Kudos
2 Replies
Highlighted
Black Belt Retired Employee
143 Views

I am not going to try to understand this large program, but the problem you describe is very unlikely to be caused by a change to the compiler or linker. (I am uncertain which compiler version you are using - there is no "Version 4". Perhaps you mean Update 4 of the 19.1 (Parallel Studio XE 2020) compiler?)

I see that the OPEN for unit LOUTPT opens FOR.06 without a STATUS value, so if the file exists it will be overwritten. As you're not specifying any folder, it opens files from whatever the current default folder is. I am unfamiliar with how MacOS works here, but it may depend on how you ran the program.

It is more likely that you made an error in the environment for running the program.  Your problem statement is not entirely clear regarding the error message, but errors of "file not found" are fairly simple to resolve.

0 Kudos
Highlighted
Black Belt
127 Views

The source file EWALD.FOR contains the string EWALD: VERSION 16 OCT 1996 in it. The output files that you attached seem to have been produced by a more recent version of that source file, since the dates in the output are 24 OCT 2020 and 03 NOV 2020. The older program, when compiled with Intel Fortran 19.1U3 on Windows and run, produces an output file that mostly matches the FOR.06.DAT that you provided, but has many more lines of apparently diagnostic output added. There were no errors or warnings during compilation and linking.

Please provide the (newer) version of the source file that produced the reference output file that you attached.

I observed that the program does use some variables before they are initialized. More investigation may reveal whether that is a serious error or the result of a benign oversight.

0 Kudos