Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.

Fortran in Visual Studio

Mohammed1
Novice
2,398 Views

I installed Visual Studio 2022. I then installed Intel OneAPI Base Toolkit followed by the HPC toolkit. I can create a Fortran project, but I am unable to run any code. When I write a code, the run bottom is greyed out (see attachment).  Can anyone please help?
* I am a newbie, so if you provide a solution please be detailed. Thank you.

Labels (3)
0 Kudos
1 Solution
8 Replies
Steve_Lionel
Honored Contributor III
2,377 Views
Mohammed1
Novice
2,329 Views

Thank you so much, Steve. This solved my problem. It was indeed the fact that I installed VS 2022.2 which is incompatible with Intel OneAPI. I followed the workaround mentioned in the post you shared (by Kaylee Xu), which is manually turning on the “Use the legacy native solution and build services". Thanks again, Fortran in VS 2022 works fine now.

0 Kudos
ddm1
Beginner
1,264 Views

Are there any known issues with VS Community 19  Version 16.11.27 ?

I am having trouble creating a DLL from Fortran code where I have successfully created an EXE. I get error 53 File Not Found.

I have created EXE & DLL in the past many times with prior versions of VS. I tried a number of compiler settings to resolve the issue and nothing seems to work.

0 Kudos
Andreas_Z_
New Contributor I
2,376 Views

From your screenshot, it seems as if you have not added your Source1.f90 to a Fortran project (and the open solution) - and that would explain why you cannot compile/run the code. Try making a new solution with an empty Fortran project, then right-click on the project name in the Solution Explorer window and select Add > Existing item > [add your .f90 file here].

0 Kudos
Mohammed1
Novice
2,345 Views

I see what you are saying but it seems that part of the problem is that I am unable to add a Fortran file to a solution. If I create a new project and right click on the solution from the Solution Explorer,  I can select Add > New Item but there is not Fortran files in the list. I can add a file.txt and change its extension to .f90 but that doesn't work either.

0 Kudos
Andreas_Z_
New Contributor I
2,336 Views

See Steve Lionel's comment and the detailed information in the provided link. You have likely installed the latest version of Visual Studio 2022, which is not (yet) supported by Intel Fortran at this time.

Mohammed1
Novice
2,328 Views

Yup, problem solved following the workaround described in Steve's post. Thank you!

0 Kudos
Steve_Lionel
Honored Contributor III
1,243 Views

@ddm1 your problem is entirely different. Please start a new thread. Also, it would help if you mentioned that you are calling your DLL from Visual Basic, which I am fairly certain you are.

0 Kudos
Reply