Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
119 Views

Highlighting of statement blocks malfunctions in XE2019

Hello, I have a licence for Intel Visual Fortran XE2011 and I am currently evaluating XE2019 to migrate my code.

However, I noticed that statement blocks, like IF ... THEN ... END IF are not highlighted anymore, as they used to be.
The VS relevant options, both in my old project in VS2010 as well as now in VS2019 are:
"Enable Outlining" = True
and
"Outline statement blocks" = False

If I turn "Outline statement blocks" to True:
1) It misses a lot of block statements. It was never perfect in identifying some block statements, but now its much worse.
2) It also puts a +/- node around the blocks it finds. This way, I can't expand/collapse the whole program unit (i.e. sub, or function), which is a drawback for me.
This used to work fine back in XE2011 with "Outline statement blocks" = False, so I am looking for a way to bring back this feature, as it helps a lot.

Is there anything I could do to make it work properly in XE2019? Some option I missed in VS maybe?

Thanks in advance.

0 Kudos
7 Replies
Highlighted
Valued Contributor III
119 Views

I don't know the cause of your problem but the functionality works 100% OK for me in XE2019 and indeed all previous versions using the default install settings.

0 Kudos
Highlighted
119 Views

To clarify what I mean by "Highlighting of statement blocks" as it used to be in XE2011, please view the screen capture attached ("Highlighting of statement blocks.JPG").

When the cursor is placed on the DO, or END DO keyword shown, they both become highlighted, so you can easily identify the extents of the specific statement block.

This doesn't work anymore in XE2019...

0 Kudos
Highlighted
Valued Contributor III
119 Views

OK I misunderstood I was considering syntax highlighting. 

That said the feature you describe works OK for me in VS2017/XE2019 I can't say for other versions as it is not a feature on my radar as I don't make use of it. It does appear to be switched on by default though I haven't messed with the settings.

0 Kudos
Highlighted
Valued Contributor III
119 Views

Also note that it works for me (VS2017) and I have "Enable Outlining" True and "Outline statement blocks" False  which are default settings. 

That is in Tools>Options>Text Editor> Fortran > Advanced > Outlining

Maybe it is a VS 2019 problem or maybe your install is a bit broken..... 

0 Kudos
Highlighted
119 Views

Thanks for your time andrew_4619.

I might try installing VS2017 just in case its a VS2019 malfunction. I also tried switching back to the VS2019 defaults, but again, I saw no highlighting.

I was hoping it might be some sort of setting I missed, so if anyone has come across it, I 'd be grateful to let me know.

Thanks again, anyway!

 

0 Kudos
Highlighted
Beginner
119 Views

Hi Giannakos,

I am using VS2019, version 16.6.1 and that feature works, so it doesn't seem to be specifically a VS2019 problem. Note sure what settings you need to change, but I think that I didn't change any of the defaults. In VS under Tools > Options > Text Editor > Fortran > Advanced, all settings are on "False". 

 

0 Kudos
Highlighted
119 Views

I don't know how it happened, but now it works!

I think it has to do with intellicode, cause I disabled all intellicode options last night and today it works fine. I did so because it seemed to hang for a second while editing text, such as after a copy-paste, or undo. Disabling the intellicode options (Tools> Options> Intellicode) seems to have sorted both problems.

Thank you both for helping.

0 Kudos