Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
6 Views

IDE integration for VS2015 installed after installing XE Composer 2016

Jump to solution

How do I enable fortran integration into VS2015 (new project etc) when I installed VS 2015 *after* installing XE Composer 2016? 

(The fortran integration files mentioned in https://software.intel.com/en-us/articles/troubleshooting-fortran-integration-issues-with-visual-studio are not available in the folder for VS 2015)

TIA

0 Kudos

Accepted Solutions
Highlighted
Employee
6 Views

Unfortunately there was no

Jump to solution

Unfortunately there was no definitive findings in the case that I submitted to Development and my internal tracking id was closed. In my case, the condition was finally cleared by uninstalling all IVF packages and re-installing them.

I don’t know if this additional information will help or not but it was added to my internal tracking id before it was closed.

There were findings about a variation posted to my internal tracking id with the same side effects involving Intel Visual Fortran along with a related C++ scenario in our C++ Forum here, https://software.intel.com/en-us/forums/intel-c-compiler/topic/599398.

For the variant involving IVF, here’s what the user wrote having done when hitting this issue:

1. Install IPSXE 2016 Update 1 Composer Edition for Fortran Windows using the online installer.
2. Install VS 2015.
3. Launched the IPSXE 2016 Update 1 Composer Edition installer from Control Panel>Programs>Programs and Features and selected Modify.

VS 2015 appeared grayed out.

I then tried the following....

1. Download IPSXE 2016 Update 1 Composer Edition for Fortran Windows offline installer.
2. Launched offline installer and selected Modify.

This time VS 2015 was not grayed out and I was able to complete the installation of the IDE integration.

Regarding the scenario above, our Developers said the behavior above was correct.  To paraphrase their reply, they indicate when you install with online installer (VS IDE integration in the case above) and then launch the installer via Control Panel, then the installer is launched in offload mode and this only allows one to modify installed components; it does not allow you to download new components (i.e. VS IDE 2015 integration in the case above). Thus, the VS2015 integration checkbox is greyed out because no installation media is available on the user's system for the VS IDE 2015 integration. Therefore, launching the setup.exe from full offline image is the only correct path to install VS IDE 2015 integration for VS2015 in this scenario.

View solution in original post

0 Kudos
16 Replies
Highlighted
6 Views

In Control Panel > Programs

Jump to solution

In Control Panel > Programs and Features, select Intel Parallel Studio and do a Change (or Modify). The installer will ask if you want to modify, uninstall or reinstall - select modify. On one of the screens you'll be shown a set of checkboxes for VS versions - check the one for VS2015 and continue. 

Retired 12/31/2016
0 Kudos
Highlighted
Beginner
6 Views

Thanks.

But the checkbox is greyed out for VS 2015 (this is after a restart of computer after installing VS 2015) in the 'Choose Integration Target' screen of the install wizard.

Something else I should be looking for?

0 Kudos
Highlighted
6 Views

Perhaps you didn't choose a

Jump to solution

Perhaps you didn't choose a "Custom" install of VS2015 and check the box for C++. By default, VS2015 doesn't install C++ support and Fortran needs that. Go back and modify the VS2015 install to add C++ and try again.

Retired 12/31/2016
0 Kudos
Highlighted
Beginner
6 Views

Installed the C++ and tried

Jump to solution

Installed the C++ and tried the XE modify option - still would not show up. attached image.

 

Capture.PNG

0 Kudos
Highlighted
Employee
6 Views

I was wondering whether you

Jump to solution

I was wondering whether you were using Update 1, it wasn't clear until your last post. I experienced the same issue on one of my systems and reported this to the Installation/IDE integration Developers earlier this week. (Internal tracking id: DPD200379248).

0 Kudos
Highlighted
Beginner
6 Views

Update1 of VS or XE or both?

Jump to solution

Update1 of VS or XE or both? Anyway I can subscribe or be notified of the fix for this?

Alternatively, do I need to re-install XE Composer to have that integration enabled with VS 2015?

0 Kudos
Highlighted
Employee
6 Views

I meant Parallel Studio XE

Jump to solution

I meant Parallel Studio XE 2016 Update 1. Unfortunately I don't know of a work around at the moment. I haven't tried a re-installation so I don't know whether that will work. We will keep you updated on a fix or work around as soon as we hear about it.

0 Kudos
Highlighted
6 Views

Interesting - I went through

Jump to solution

Interesting - I went through this myself yesterday and didn't have a problem.

Retired 12/31/2016
0 Kudos
Highlighted
Beginner
6 Views

i did it ,thanks

Jump to solution

i did it ,thanks

0 Kudos
Highlighted
Beginner
6 Views

I'm having the same problem

Jump to solution

I'm having the same problem as the thread starter, i.e. the VS 2015 tick box is greyed out when I try to install Parallel Studio XE 2016 Update 2 . The C++ option in VS 2015 is installed, and I currently use Parallel Studio XE 2016 Update 1. Any sollution to the problem?

best regards

0 Kudos
Highlighted
Employee
7 Views

Unfortunately there was no

Jump to solution

Unfortunately there was no definitive findings in the case that I submitted to Development and my internal tracking id was closed. In my case, the condition was finally cleared by uninstalling all IVF packages and re-installing them.

I don’t know if this additional information will help or not but it was added to my internal tracking id before it was closed.

There were findings about a variation posted to my internal tracking id with the same side effects involving Intel Visual Fortran along with a related C++ scenario in our C++ Forum here, https://software.intel.com/en-us/forums/intel-c-compiler/topic/599398.

For the variant involving IVF, here’s what the user wrote having done when hitting this issue:

1. Install IPSXE 2016 Update 1 Composer Edition for Fortran Windows using the online installer.
2. Install VS 2015.
3. Launched the IPSXE 2016 Update 1 Composer Edition installer from Control Panel>Programs>Programs and Features and selected Modify.

VS 2015 appeared grayed out.

I then tried the following....

1. Download IPSXE 2016 Update 1 Composer Edition for Fortran Windows offline installer.
2. Launched offline installer and selected Modify.

This time VS 2015 was not grayed out and I was able to complete the installation of the IDE integration.

Regarding the scenario above, our Developers said the behavior above was correct.  To paraphrase their reply, they indicate when you install with online installer (VS IDE integration in the case above) and then launch the installer via Control Panel, then the installer is launched in offload mode and this only allows one to modify installed components; it does not allow you to download new components (i.e. VS IDE 2015 integration in the case above). Thus, the VS2015 integration checkbox is greyed out because no installation media is available on the user's system for the VS IDE 2015 integration. Therefore, launching the setup.exe from full offline image is the only correct path to install VS IDE 2015 integration for VS2015 in this scenario.

View solution in original post

0 Kudos
Highlighted
Beginner
6 Views

Update 2 has the same issue.

Jump to solution

Update 2 has the same issue. It's not fixed. This time around, the problem was with VS 2010. I had installed IPSXE 2016 Update 2 on a PC with VS2010 (without C++). Installed C++ in VS 2010 and Repair/Uninstall SXE didn't help.

Finally, had to uninstall the entire SXE, reinstall it, and then it was able to detect VS2010.

I have not tried Kevin's solution (2)  above of running the offline installer and modifying the SXE. That may have been a simpler approach than mine.

Can some one from Intel comment why this is not being addressed? Alternatively, can someone post the 'repair' packages so they can be run manually instead of going down the (re)install route? I had created a premier ticket back in October 2015 -- #  6000145087 and it still shows 'escalated to engineering' !!

0 Kudos
Highlighted
6 Views

If the developers can't

Jump to solution

If the developers can't reproduce the problem, they are generally unable to fix it. This issue is not common, though it does happen.

There isn't a "repair package". You can do a Change/Modify through Control Panel > Programs and Features, but depending on how you installed the product the necessary components may need to be reinstalled. You can also see if the repair tips in https://software.intel.com/en-us/articles/troubleshooting-fortran-integration-issues-with-visual-studio/ help.

Retired 12/31/2016
0 Kudos
Highlighted
Beginner
6 Views

Thanks Steve - I was

Jump to solution

Thanks Steve - I was referring to the scripts as 'package' mentioned in the repair tips you posted. Elsewhere on the forums, I saw someone post a zip file of the contents of \Intel Fortran\VFPackages folder which when run manually might add the support to that version of IDE.

0 Kudos
Highlighted
6 Views

I wouldn't trust that.

Jump to solution

I wouldn't trust that.

Retired 12/31/2016
0 Kudos
Highlighted
Beginner
6 Views

That worked for me too. I did

Jump to solution

That worked for me too. I did as follows:

Launched the offline installer for IPSXE 2016 Update 1.
Now I got the option of modifying the existing installation, and it was possible to check the VS2015 integration checkbox.
When the IPSXE 2016 Update 1 installation was modified I launched the IPSXE 2016 Update 2, and it was now
possible to check the VS2015 integration checkbox there as well.

 

0 Kudos