Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
26750 Discussions

Mixed language dll - c files are ignored.

Kantor__Baruch
Beginner
87 Views

Hi,

I'm using Composer XE 2018 with VS 2015 to create a Fortran DLL. I've added to the project a C source file but in the build process it is simply being ignored. My workaround was to create a C static library project and add the lib file to the Fortran DLL project but I prefer to have them all in one project. Have I missed something?

Thank you

Baruch

0 Kudos
3 Replies
IanH
Black Belt
87 Views

The separate static library is the way things are meant to be done. 

A Fortran project is basically a set of settings for the Fortran tool chain to build something, that Fortran tool chain doesn't understand C source.

Mixed language projects used to exist, but that is now ancient history.

Kantor__Baruch
Beginner
87 Views

Thank you!

The happy days of CVF have gone...

Steve_Lionel
Black Belt Retired Employee
87 Views

Microsoft did away with the ability to have mixed-language projects in VS.NET 2002.

You'll also want to read https://software.intel.com/en-us/articles/configuring-visual-studio-for-mixed-language-applications

Reply