Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
27414 Discussions

OneAPI 64-bit debug version raises compilation error in MSVS2019

avinashs
New Contributor I
653 Views

I am unable to use 64-bit debug versions due to the following error that causes compilation to fail. There is no problem with 32-bit debug versions.

Unable to start debugging. Unexpected GDB output from command "-target-select-remote localhost:1234". localhost:1234: Connection timed out.

Is there a need to reinstall debugger? If so, how? Thanks.

0 Kudos
1 Solution
Steve_Lionel
Black Belt Retired Employee
495 Views

Without rebuilding anything, your 64-bit project starts normally in the regular debugger for me. You must have some odd setting in Visual Studio itself to cause it to try to connect to gdb.

View solution in original post

7 Replies
Steve_Lionel
Black Belt Retired Employee
637 Views

Can you describe in more detail what you are doing? What kind of application are you building and how do you start debugging? Remote debugging is not something typically done on Windows. Please ZIP and attach the build log from a rebuild of your project.

avinashs
New Contributor I
575 Views

@Steve_Lionel It is a standard project with a main program linking to a 64-bit library. As mentioned, it works in 32-bit. Attached are the error messages and GDB configuration in MSVS 2019.

Steve_Lionel
Black Belt Retired Employee
564 Views

You didn't supply what I asked for. 

Debugging normal Windows executables doesn't involve GDB.  I'm not sure exactly what you have done (which is why I asked for a ZIP of your project file, not a screenshot of some messages), but it looks as if you've somehow configured your project to think it is using a graphics card through OneAPI. You want to use the IFORT (CLASSIC) compiler.

Create a new project as a Fortran Console application and go from there.

avinashs
New Contributor I
517 Views

@Steve_Lionel  Thank-you for your valuable time. I have created a reproducible example which includes a sample project stored under C:\Temp. On my machine, the 32-bit version works but not the 64-bit. It generates the same messages that I previously attached. I have verified this with multiple projects.

Steve_Lionel
Black Belt Retired Employee
496 Views

Without rebuilding anything, your 64-bit project starts normally in the regular debugger for me. You must have some odd setting in Visual Studio itself to cause it to try to connect to gdb.

avinashs
New Contributor I
480 Views

Thanks for the helpful hint @Steve_Lionel . After some effort, I found the setting creating the problem. The entry

Tools -> Options -> Intel oneAPI -> Intel Distribution for GDB -> General -> Enable Debugging -> True

was automatically set during installation by oneAPI. This causes an error in 64-bit but not in 32-bit. I changed it to False and now the error disappears. Somewhat nonintuitive is that when set to False, debugging works in 32-bit and 64-bit whereas if True, debugging works only in 32-bit. See the file Options GDB.png in the earlier attachments.

andrew_4619
Honored Contributor II
471 Views

I suspect GDB is only 64 bit.

Reply