Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner

Problem installing Fortran 11.1 on MacOS

I actually had two problems installing m_cprof_p_11.1.091.dmg on my Mac running Sierra Version 10.12.6.

The first was that apparently since Mac OS 10.5, Apple is no longer putting Xcode in /Developer/Applications.  Fixing that was pretty easy with a link to where Xcode is currently installed.  The second issue is that the installer tells me "Unsupported OS version"  "Only 10.5.x or higher OS versions are supported."  Sadly, my OS version IS higher than 10.5, being 10.12, but I guess that mathematically speaking they are checking to see if 10.12 is numerically higher than 10.5 and it is not.  Is there any way to force the install?

The reason I want to install 11.1 is that I am trying to port a very large Fortran program to the Mac for the very first time and Intel Fortran 11.1 is a version of the compiler that I know for sure correctly compiles a running version of the program.  Any help would be greatly appreciated.

 

0 Kudos
1 Reply
Highlighted
Black Belt

Unfortunately, MacOS tends to

Unfortunately, MacOS tends to have more compatibility issues than Windows and Linux put together. I remember that just about every MacOS update, no matter how minor, moved things around and introduced library/linker incompatibilities that required adjustment on Intel's side.

I recommend trying the current, supported version of the compiler. If you have problems compiling, ask for help here.

Steve (aka "Doctor Fortran") - https://stevelionel.com/drfortran
0 Kudos