Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
51 Views

[Updated] Problems with PSXE 2017 Update 4 and VS 2017 (missing rc.exe and digitally not signed drivers)

Hi,

I am trying to install Update 4 with VS 2017. In short, I am facing the "rc.exe not found" error that was also present with VS 2015 but the instructions found on this forum don't seem to apply as I don't see any option to include "Common tools", and I did select "Desktop development with C++" when installing VS 2017.

More details:

This is a clean install of Windows 10 (1703), so no previous VS or PSXE versions are present.

When installing VS 2017 (Professional), I have selected only the "Desktop development with C++" Workload.

When installing PSXE 2017 Update 4, I received 3 warnings:

  • System reboot may be required for extended GPU analysis
  • Additional requirements for using Intel C++ compiler to offload application computation to Intel Graphics Technology
  • Missing Visual Studio C++ 2012, with a link to the Redistributables

I downloaded the redistributables from the link provided in the setup (it is Visual Studio C++ 2012 redistributable update 4), downloaded and installed the x86 and x64 redistributables, re-launched the PSXE setup. The 3rd warning was gone, the first two warnings were still there but I assumed there were not important.

I then installed PSXE 2017 Update 4 (Professional) leaving all options to default.

During the setup, 2 "Program Compatibility Assistant" messages come up. Both say that Windows blocked the installation of a digitally unsigned driver. One message is about "vtss.sys" and the other one is about "Sampling Enabling Product". But the installer says it completes successfully.

If I create a new console application with the wizard, trying to build it results in an "rc.exe not found" error. Other examples fail as well.

Would anyone have any pointers?

Thanks,

Mat

 

0 Kudos
26 Replies
Highlighted
Beginner
13 Views

When I installed for the first time, the download link was still working, and I kept a local copy of the redistributable package so I did not notice whether the link was down during my successive attempts. I assume re-posting the file would breach some licensing agreement, but I will contact you off list to see if I can help.
 

0 Kudos
Highlighted
Beginner
13 Views

I can confirm that the new VTune installer (see Kevin's message #15) installs correctly on Windows 10 Creators Update. Note that I didn't see any indication on the Intel Registration Center that the file had in fact been updated (dates, version numbers etc. seemed to be unchanged when I downloaded), but apparently it is.

Also, in case anyone is reading this and scrolling to the end to find an answer, the solution I finally adopted to fix the "rc.exe" not found problem is the one suggested by Kevin in message #3. The full step-by-step instructions (for current VS2017 and PSXE 2017 Update 4) are:

In Visual Studio, Go to Tools > Options > Intel Compilers and Tools > Visual Fortran > Compilers > Executables
Under Win32 add a line with:
   C:\Program Files (x86)\Windows Kits\10\bin\10.0.15063.0\x86
Under x64 add a line with:
   C:\Program Files (x86)\Windows Kits\10\bin\10.0.15063.0\x64

I added the lines just before the last ones, which say $(PATH)

(I tried to use a combination of macros such as $(WindowsSdkDir) but I couldn't find a combination that works, so hardcoding the full path seemed easier. Before trying this you might want to check that "rc.exe" is in fact in the 2 folders listed in the lines to add.

 

 

0 Kudos
Highlighted
Beginner
13 Views

Kevin D (Intel) wrote:

Development reported the VTune driver issue you experienced relates to inadequate signed drivers for a Secure Boot Windows 10 system and that the issue is resolved in updated signed drivers now available in the Intel® VTune™ Amplifier XE for Windows* 2017 Update 3 stand-alone package available from the Intel Registration Center.

At your convenience, you can download/install this updated package. Prior to installation, please uninstall any existing Intel® VTune™ Amplifier XE for Windows* 2017 and then install this Update 3 package. Please let us know if you experience any additional issues.


Unfortunately I am has this problem even with the update 3.
I have tried to uninstall the vtune completely and reinstall it from update 3 but no luck through.
I have Windows 10 Pro with Creators Update installed (1703) OS build (15063.296).

 

 

 

 

0 Kudos
Highlighted
Employee
13 Views

@Oleg K – Please open a support request at the Intel Service Center, https://supporttickets.intel.com so we better assist you with this failure. Thank you.

Regarding the Microsoft Visual C++ 2012 Redistributable* issue:

The Microsoft Visual C++ 2012 Redistributable* (x86) requirement relates to the Debugger Fortran Expression Evaluator (FEE) DLLs that are built using Visual Studio 2012.  The requirement is applicable when using any supported Visual Studio version with Intel Parallel Studio 2017 *earlier* than Visual Studio 2017.

The download is no longer available at the link indicated in the installation messaging; however, it is available under via the Visual Studio Dev Essentials program. You may join the Visual Studio Dev Essentials (free) and install the "Visual C++ Redistributable for Microsoft Visual Studio 2012 Update 4" found within the Downloads section.

0 Kudos
Highlighted
13 Views

I'm having the same signed driver issue when installing PSXE 2018 beta update 1 on Win 10 pro x64 v1703. Should I use the registry hack that you previously recommended?

Thanks,
Chris

0 Kudos
Highlighted
Beginner
13 Views

I have (had?) the same problem as mjfort, but thanks to him, I 'temporarily" resolved it by using his "temporary" suggestion as follows:

In Visual Studio, Go to Tools > Options > Intel Compilers and Tools > Visual Fortran > Compilers > Executables
Under the Win32 tab, add a line with:
   C:\Program Files (x86)\Windows Kits\10\bin\10.0.15063.0\x86
Under x64 tab, add a line with:
   C:\Program Files (x86)\Windows Kits\10\bin\10.0.15063.0\x64
I added the lines just before the last ones, which say $(PATH)

I originally used his first solution, i.e., copying all the files from one folder to the other folder, but I like the above solution better.  I just wanted to let him know (if he reads this) that his efforts helped someone else.  Thanks mjfort!

0 Kudos
Highlighted
Beginner
13 Views

mjfort wrote:

I can confirm that the new VTune installer (see Kevin's message #15) installs correctly on Windows 10 Creators Update. Note that I didn't see any indication on the Intel Registration Center that the file had in fact been updated (dates, version numbers etc. seemed to be unchanged when I downloaded), but apparently it is.

Also, in case anyone is reading this and scrolling to the end to find an answer, the solution I finally adopted to fix the "rc.exe" not found problem is the one suggested by Kevin in message #3. The full step-by-step instructions (for current VS2017 and PSXE 2017 Update 4) are:

In Visual Studio, Go to Tools > Options > Intel Compilers and Tools > Visual Fortran > Compilers > Executables
Under Win32 add a line with:
   C:\Program Files (x86)\Windows Kits\10\bin\10.0.15063.0\x86
Under x64 add a line with:
   C:\Program Files (x86)\Windows Kits\10\bin\10.0.15063.0\x64

I added the lines just before the last ones, which say $(PATH)

(I tried to use a combination of macros such as $(WindowsSdkDir) but I couldn't find a combination that works, so hardcoding the full path seemed easier. Before trying this you might want to check that "rc.exe" is in fact in the 2 folders listed in the lines to add.

Thank you @mjfort !!!

The issue I was seeing was

1) In Visual Studio, under Tools-Options-Intel Compilers-Visual Fortran-Compilers-Executables (win32 tab),  $(WindowsSDKDir) was pointing to C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\VC\\PlatformSDK

and

2) The command prompt for Intel Visual Fortran had it set to C:\Program Files (x86)\Windows Kits\10

Both of which are incorrect. I added an explicit path to C:\Program Files (x86)\Windows Kits\10\bin\10.0.16299.0\x86 as you suggested and the rc.exe error went away.

My setup is VS 2017 15.4, Intel Fortran Composer XE 2017 Update 4  (Had to install VS 2017 15.0, install Fortran and finally update VS to 15.4)

Hopefully Update 5 of Fortran will fix this issue.

 

0 Kudos