Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
77 Views

catastrophic error: **Internal compiler error: internal abort**

Jump to solution

Hi 

I was trying to compile the stringifor project on windows 10/x64 platform (https://github.com/szaghi/StringiFor). I get this scary message. I attached a copy of of simplified solution (Visual Studio 2015 professional). Hope this is helpful.

Regards

Sam KV

1>stringifor_string_t.f90
1>010101_14247
1>catastrophic error: **Internal compiler error: internal abort** Please report this error along with the circumstances in which it occurred in a Software Problem Report.  Note: File and line given may not be explicit cause of this error.
1>compilation aborted for D:\Compilation\IVF_Bug\IVF_Bug\stringifor_string_t.f90 (code 1)

0 Kudos

Accepted Solutions
Highlighted
77 Views

Sorry for dropping the ball on this.

I can reproduce the ICE only if /check:bounds is specified. It builds fine if you don't enable this- at least for stringifor_string_t.f90

I'll send this on to the developers. Issue ID is DPD200414845.

View solution in original post

0 Kudos
7 Replies
Highlighted
77 Views

Thanks, we'll check it out. An internal compiler error is always a compiler bug. Thanks for providing a complete test case. The one thing missing is the exact compiler version you used. I can see it is 16.0, but which update?

0 Kudos
Highlighted
Beginner
77 Views

Thank for your quick response

here it is (I used About menu in Visual Studio not console /? switch) 

Intel® Parallel Studio XE 2016 Update 3 Composer Edition for Fortran Windows*     Package ID: w_comp_lib_2016.3.207
Intel® Parallel Studio XE 2016 Update 3 Composer Edition for Fortran Windows* Integration for Microsoft Visual Studio* 2015, Version 16.0.0062.14, Copyright © 2002-2016 Intel Corporation. All rights reserved.
* Other names and brands may be claimed as the property of others.

 

0 Kudos
Highlighted
77 Views

Perfect - thanks. Stay tuned....

0 Kudos
Highlighted
78 Views

Sorry for dropping the ball on this.

I can reproduce the ICE only if /check:bounds is specified. It builds fine if you don't enable this- at least for stringifor_string_t.f90

I'll send this on to the developers. Issue ID is DPD200414845.

View solution in original post

0 Kudos
Highlighted
Beginner
77 Views

Dear Sam and Steve,

thank you for your help.

I like to add some data. The same ICE happens on Arch Linux (a GNU Linux distro) with Intel Fortran Compiler 16.0.3 and 17.0.0 Beta only when check-bounds is invoked.

My best regards.

0 Kudos
Highlighted
77 Views

That doesn't surprise me. It's rare for a compiler bug like this to be OS-dependent.

0 Kudos
Highlighted
77 Views

I am told that this bug will be fixed for Update 2 to Parallel Studio XE 2017.

0 Kudos