Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
14 Views

fortran installation and integration with Visual Studio

At last I have decided to install IVF 2017 last update. 
My application development environment was IVF2016 integrated with VS2015.
Before this last step I have installed about 2 months ago MS VS2017.
My hope was to keep the IVF2016/VS2015 unchanged and integrate IVF2017 with VS2017 only
The installation of IVF2017 has provided NO WARNINGS and NO OPTION SELECTION and at the end IVF2017 has replaced IVF2016  in the VS2015 installation. 
How is it possible to destroy a professional development environment ??
Both Intel and MS products are professional version.
So a basic question to Intel engineers: how can I get the described limited integration ? 
Congratulations to Intel engineers !  

 

 

 

0 Kudos
4 Replies
Highlighted
Moderator
14 Views

This article explains how

This article explains how customize your IDE integration and select VS version during installation: https://software.intel.com/en-us/articles/using-older-intel-visual-fortran-versions-in-different-mi...

Devorah - Intel® Developer Support
0 Kudos
Highlighted
New Contributor I
14 Views

I was willing to customize my

I was willing to customize my installation but I have never seen any dialog requesting IDE integration options.
The only request was a license code. As far as I remember I have only selected to install all products (advisor, inspector, etc.)
The same behavior I found with the IVF2016 installation and I opened a ticket with premier support. 
I hoped things had changed meanwhile.

Regards

  

 

0 Kudos
Highlighted
Moderator
14 Views

This dialog is available for

This dialog is available for PSXE 2018 (IVF 18.0) or later.

In addition, VS2017 is not fully supported in PSXE 2017 (IVF17.0) Please refer to RNs for IVF 17.0 and IVF 18.0 for supported VS versions.

Devorah - Intel® Developer Support
0 Kudos
Highlighted
New Contributor I
14 Views

A selection dialog of the

A selection dialog of the desired Visual Studio integrations was also available with some installation before IVF2016 but disappeared afterwards.
This was the reason of the of the ticket opened with the IVF2016 installation.
In addition, I downloaded the IVF2017 professional version installation kit (all products), in this case, during installation, I a dialog for the selection of the Intel product  to be installed (Vtune, Amplifier, etc.) would be welcome.  

0 Kudos