Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
8 Views

ifort command line installation with Parallel Studio XE 2018 and VS2017

Hello all, 

My apologies if I missed this issue in searching through the forums.  I've rolled over to XE 2018 Update 2 Composer Edition (w_comp_lib_2018.2.185) and VS2017 15.6.6 (win 10 machine).  From VS2017 itself,  I ran the hello world console example program and it appears to be integrated and to compile just fine, however the command line version of ifort does not seem to work for me.  

Post-install of both programs, I followed the Intel getting started guide: C:\Program Files (x86)\IntelSWTools\documentation_2018\en\ps2018\getstart_comp_wf.htm , 

When I run .\psxevars.bat from the powershell or attempt to use the command line tools ("Compiler 18.0 Update 2 for Intel 64 Visual Studio 2017 environment") from the start menu , I get the following message:

Via Powershell:

PS C:\Program Files (x86)\IntelSWTools\parallel_studio_xe_2018.2.046\bin> .\psxevars.bat intel64 vs2017

Output below:

Intel(R) Parallel Studio XE 2018 Update 2
Copyright (C) 2018 Intel Corporation. All rights reserved.


ERROR: Visual Studio 2017 is not found in the system.

Is there something I've done wrong such that VS2017 cannot be located?  Thank you for any help and/or pointing me in the right direction to work on fixing.  

0 Kudos