Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Beginner
352 Views

intel fortran MAC OSX 10.11

hi 

i was usinig mac osx 10.10.5 and intel compiler fortran 2015 and everything worked just fine , after updating to mac osx 10.11 when i use ifort in terminal it says " command not found " but gfortran 5.1 works fine . any suggestion ?

0 Kudos
15 Replies
Beginner
352 Views

I had the same issue that Intel Fortran compiler stopped working on Xcode after upgrading to El Capitan. `ifort` is no longer symlinked in `/usr/bin` due to new security system. You could still access it from `/opt/intel/bin` though.

With that, here is my workaround for Xcode integration, if you're on the same boat:

1. Open `/Library/Application Support/Developer/7.0/Xcode/Plug-ins/IFORT 16.0 Compiler.xcplugin/Contents/Resources/IFORT 16.0.0.xcspec` with your text editor.

2. Replace any occurrence of `/usr/bin/ifort-16.0` with `/opt/intel/bin/ifort`. I had 3 of them.

3. Save the file. You may be asked administrator access.

4. Run Xcode and try building your Fortran projects.

0 Kudos
Employee
352 Views

Thank you for your posts and sharing this work around. This relates to details discussed here, https://software.intel.com/en-us/articles/os-x-1011-not-supported-by-intel-parallel-studio-xe-2015, As noted in the article, the official OS X* 10.11 support will be provided in a coming PSXE 2016 update.

0 Kudos
Beginner
352 Views

Dear Bloggers,

I am using OS X* 10.11 with PSXE 2016 (update 5). Few days ago it was working fine but suddenly this error started to appear when I was trying to compile my fortran projects:

error: can't exec '/usr/bin/ifort-16.0' (No such file or directory)

Command /usr/bin/ifort-16.0 failed with exit code 71

 

Any ideas about how to solve this problem? 

Thanks, Diego 

 

0 Kudos
Beginner
352 Views

thanks Kyung Dahm Y for your response and that was a great idea and it worked . I just add this that opt is hidden now and if you search opt in Macintosh HD you will find it or just press cmd+shift+g and in the box type /opt .

I also used this command to be able to use ifort in terminal :

run terminal and type :

source /opt/intel/composer_xe_2015.2.132/bin/compilervars_arch.sh intel64

note that " /opt/intel/composer_xe_2015.2.132 " this address is based on your intel fortran version and you can simply find the latest version on opt/intel folder .

then you will be able to use ifort in terminal but each time you should run this command when reopen terminal or go to terminal preference and in shell tab check the the box of run command and type the command (source /opt/intel/composer_xe_2015.2.132/bin/compilervars_arch.sh intel64),this will run the command automatically after opening terminal .

second way is to use

 /opt/intel/composer_xe_2015.2.132/bin/intel64/ifort ( space ) "address of your file that you want compile"

the second way is useful when using alternative IDE like CodeRunner , and use this in run command option.(again "/opt/intel/composer_xe_2015.2.132" is based on your installed version)

 

0 Kudos
Employee
352 Views

@Diego S. - Just a clarification. The “update 5” is associated with the PSXE 2015 release and not the newest PSXE 2016 release. Regarding your error, maybe you were using the OS X* Beta 10.11 a few days back and perhaps your system is upgraded the official release?  Or somehow your system is now subject to the System Integrity Protection. The symptoms you described are a by-product what Kyung Dahm Y. described in his post #2 that changed related to the System Integrity Protection. If you are using Xcode, perhaps Kyung Dahm Y.'s recipe might work.

We expect you should be able to use the compiler via the command-line simply by source-ing the /opt/intel/bin/compilervars.sh (or csh) script (e.g. source /opt/intel/bin/compilervars.sh intel64) that installs with the PSXE 2016 release.

@ramin a. - I do not recommend using the “_arch” version of the compiler setup script. That is not the main setup script and when it is used the environment is not fully setup to use the compiler, debugger, and MKL. I recommend using the main compilervars.sh (or .csh) script. There is also a simpler path you can use:   /opt/intel/composer_xe_2015/bin/compilervars.sh (or .csh)

0 Kudos
Beginner
352 Views

Dear Kevin, thanks for your reply. I did what Kyung Dahm recommended however, intel fortran is not shown in Xcode as an option for a fortran compiler. I used to find it in the "Build Rules" tab when I added a new rule (Fortran source files using script-tab "using" had the intel fortran option). 

As a result when I could't compile the program. Any ideas.

Thanks for your attention,

Diego 

0 Kudos
Employee
352 Views

Unfortunately I do not have any suggestions for making either the PSXE 2015 or PSXE 2016 releases backward compatible with the changes imposed by this new System Integrity Protection feature. We are working to resolve the issues introduced by the System Integrity Protection in our next Parallel Studio XE 2016 Update 1. I'm sorry, I wish I had something to help.

I have never reverted to an earlier OS on the Mac before so I don't know if that's feasible but if so perhaps backing up to OS X* 10.10 and PSXE 2015 Update 5 might be the better option for now.

I will update this forum thread with any new information that I receive.

0 Kudos
Beginner
352 Views

Dear Kevin,

Thanks for your reply. Is there any estimated time for update 1 to come out?

Best,

Diego 

 

0 Kudos
Employee
352 Views

Hi Diego - The tentative scheduled release of PSXE 2016 Update 1 is early next month.

0 Kudos
Beginner
352 Views

Hello,

I only use the Fortran compiler with command line in Terminal, not Xcode. To make PSXE 2016 to work, I disabled System Integrity Protection in El Capitan by rebooting into Recovery More by holding down Command + R and then in Terminal issuing

"csrutil disable".

Then I restarted the Mac normally and have reinstalled the compiler. The compiler now works fine. Maybe this procedure will also allow it to work via Xcode.

Peter N.

 

0 Kudos
Beginner
352 Views

 

I applied  the students free Intel Parallel Studio XE Composer Edition for Fortran OS X and got serial number. 
 

I download  the 2016 version but it's  'm_fcompxe_2016.0.033.app' and double-click couldn't work to install it. 
 

Then I downloaded the 2015 version, and it's a mpkg file and it can be installed but after offering my serial number, it told me 'The Serial Number provided is not valid for this solution set'.
 

what should i do to solve these problems? thanks.
 

0 Kudos
Beginner
352 Views

I am a user of OSX 10.11.1 (but the following happened while I was using OSX 10.10).

It seems to me since I started to use /opt/intel/composer_xe_2015.3.187/compiler, I have been encountering the following troubles.

When my code run, I have the message

dyld: Library not loaded: libmkl_intel_lp64.dylib
  Referenced from: /Users/iwatasue/bin/Molyx/debug/two.x
  Reason: image not found

I examined the environment as

KyoRyu:/<3>Molyx/Ne_n%printenv |grep DYLD
65:DYLD_LIBRARY_PATH=/opt/intel/composer_xe_2015.3.187/compiler/lib:/opt/intel/composer_xe_2015.3.187/compiler/lib/intel64:/opt/intel/composer_xe_2015.3.187/compiler/lib:/opt/intel/composer_xe_2015.3.187/mkl/lib:/opt/intel/Compiler/11.1/058/lib:/opt/intel/Compiler/11.1/058/lib/intel64


Obviously the link was correctly set. 

Could somebody help me?

0 Kudos
Employee
352 Views

0 Kudos
Beginner
352 Views

Hi,

I have upgraded to OS X El Capitan (version 10.11.4). Following 

https://software.intel.com/en-us/articles/installing-intel-compilers-for-os-x-pre-requisite-xcode-co...

I installed Xcode (version 7.3) and command line developer tools. I am trying to install Intel(R) Parallel Studio XE 2015 package. I have downloaded all the latest versions of the Intel(R) Parallel Studio XE 2015 package via Intel(R) Software Manager but when I try to activate it using the Manager it says:

"The serial number you entered is not valid. Please enter a valid serial number and try activating the product again"

Since it is not activated when I issue fort in the command line I receive the following error:

Error: A license for FCompM is not available (-76,61026,2).

 

License file(s) used were (in this order):

    1.  Trusted Storage

**  2.  /opt/intel/composer_xe_2015.6.232/licenses

**  3.  /opt/intel/licenses

**  4.  /Users/Fatemeh/intel/licenses

**  5.  /Users/Shared/Library/Application Support/Intel/Licenses/*.lic

**  6.  /opt/intel/composer_xe_2015.6.232/bin/intel64/../../Licenses

**  7.  /Users/Fatemeh/Licenses

**  8.  /opt/intel/composer_xe_2015.6.232/bin/intel64/*.lic

 

Please visit http://software.intel.com/sites/support/ if you require technical assistance.
 

Could you please inform me whether Intel(R) Parallel Studio XE 2015 support OS X El Capitan at all? If not what I should do?

Thank you

0 Kudos
Beginner
352 Views

Hi

I know it doesn't help but I reinstalled my old copy of ifort 2014 and new 2017 beta and I didn't have any issues on my mac book pro and imac with 10.11.4. The imac is factory fresh last week and didn't come with SIP enabled , ie can still root etc. strange!

regards

Steve

 

0 Kudos