Intel® Fortran Compiler
Build applications that can scale for the future with optimized code designed for Intel® Xeon® and compatible processors.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

omptarget.dll was not found

Noemig4
Beginner
672 Views

I am trying to run an executable that I compiled using Intel® Fortran Compiler (Beta) (ifx). I compiled the executable in Microsoft Visual Studio 2019 (VS). My intention is to use the offload capability (IntelOneAPI and OPenMP 4.5). I have turned on the offload switch in the project properties. When I tried to run the executable I get the following error message: AZFD.exe system Error: "The code execution cannot proceed because omptarget.dll was not found. Reinstalling the program may fix this problem."

I have the omptarget.dll located in two places in the INTEL subdirectory. I made sure that this path is also in the VS project properties. I also copied the omptarget.dll to the LIB folder that I have as an additional include libraries path in my FORTRAN properties in the VS project. No matter where I put the omptarget.dll, the executable still doesn't find it.

If I copy the omptarget.dll to the same folder where I have my executable, the error changes to: "The ordinal 899 could not be located in the dynamic link library".

Thanks in advance for any advice.

Labels (2)
0 Kudos
6 Replies
andrew_4619
Honored Contributor I
617 Views

I presume you do no direct loadlibrary / getprocaddress in your code so that would rather suggest that you have the wrong dll installed. Maybe you need a compatible OMP install? A dumpbin of that dll on my system defines ordinals 1 through to 59......

Barbara_P_Intel
Moderator
594 Views

I am concerned that you wrote "I have turned on the offload switch in the project properties".  There is an /qoffload switch, but that is related to the MIC architecture processors, i.e. KNL, KNM.  It has nothing to do with ifx and using OpenMP TARGET directives to offload to Intel integrated or discrete GPUs.

Have you read this Getting Started Guide? It's light on Windows and Fortran, but does cover the basics, including compiler options.

 

Noemig4
Beginner
312 Views

The following are the switches that I turned on. I think the problem is with the  omptarget.dll. I have been unable to fix this issue.  Still getting the error  "The ordinal 899 could not be located in the dynamic link library".  

 

Noemig4_0-1640209162748.png

 

ralphbottombody
Beginner
538 Views

I have the identical problem.  I re-installed oneAPI Base and HPC and the error persists.  There are only two omptarget.dll files and they are the same and current from 6/19/2021.  The path is correct in the Project Properties.  I copied the omptarget.dll into the folder with the executable  and got the same ordinal 899 error message.  Another dll or other resource that is referenced in address 899 of the omptarget.dll needs to be identified and I have searched the "Getting Started Guidelines" without success.  Can someone from Intel please tell us what is missing

andrew_4619
Honored Contributor I
293 Views

If you have missing dll's why not try an install of the redistributables for intel fortran/omp, the links are on this page.

 https://www.intel.com/content/www/us/en/developer/articles/tool/oneapi-standalone-components.html

 

first you had a missing omptarget.dll  and when you bodged a copy of omptarget.dll  you got the ordinal 899 error. omptarget.dll  does not have an ordinal 899 some it must be some other dll. This all just suggests your install is Brocken or incomplete. That is what you need to fix. There are plenty of threads on that topic.

Noemig4
Beginner
281 Views

Thank you Andrew for the link, I will try to reinstall everything again and see if I can identify the missing piece.

 

I have reinstalled twice the oneAPI Base and HPC  with no success.

Reply