Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
441 Discussions

Devcloud qsub: submit error (Unauthorized Request MSG=group ACL is not satisfied: user u37667@login-2, queue batch)

TTwom
Novice
560 Views

On devcloud I am trying to login to nodes that run X2GO and quartus. I am able to login using the devcloud_login script to options 2 (Arria 10 OneAPI) and 4 (Compilation Only) nodes but not any others.

 

The command generated by devcloud_login is:

running: qsub -q batch@v-qsvr-fpga -I -l nodes=s001-n137:ppn=2

 

and the error is:

qsub: submit error (Unauthorized Request MSG=group ACL is not satisfied: user u37667@login-2, queue batch)

 

0 Kudos
4 Replies
MEIYAN_L_Intel
Employee
462 Views

Hi,

May I know that do you sign up via https://software.intel.com/en-us/devcloud/FPGA?

 

I had tried to use command "devcloud_login" with the login node: qsub -q batch@v-qsvr-fpga -I -l nodes=s001-n139:ppn=2.

I found that this cost a lot of time to login to the node.

 

I am checking internally with the developer. I will replied here when I received the reply from developer.

 

I had tried choose the option 5 with node selected and it can successful login, could you try to login with option 5 (enter specific node number).

 

For your information, the Arria 10 PAC Card Programming node is s001-n138 and s001-n139 and Stratix 10 PAC Card Programming node is s001-n189.

 

Thanks

TTwom1
Beginner
462 Views

Sorry for the delayed response. I had to create a new forum account as my old one was continuously redirected away from this site.

 

I believe that I signed up using the one-api link. (https://intelsoftwaresites.secure.force.com/devcloud/oneapi)

 

The issue is still happening. It does not time-out, but returns immediately with that error.

I assume that this is because I do not have the correct permissions. Is there a way for me to get those permissions?

 

Thanks

Lawrence_L_Intel
Employee
462 Views

Sometimes it takes up to four minutes from requesting a node to logging in. That behavior can be sporadic as sometimes it will login immediately. The wait time seems to be predicated on you logging out and back in repeatedly. You can also submit batch jobs per the instructions: https://github.com/intel/FPGA-Devcloud/tree/master/main/Devcloud_Access_Instructions#70-job-control-... . Note you will need to setup the environment paths and variables in you login script should you choose to submit batch jobs.

Let us know if you have additional questions. Thanks

Lawrence_L_Intel
Employee
462 Views

Looks like you signed up the OneAPI side of the devcloud, not the FPGA side of the devcloud. You can verify by typing groups. If groups returns c009 ,but not c009 c009-fpga, then you are on the OneAPI side. Provide us your u# and we can move you over to the FPGA side which is a superset of OneAPI - you'll gain access to 12 additional nodes with 10xArria 10 and 2x Stratix 10. Feel free to email me directly if you need to get your account moved over. lawrence.landis@intel.com .

 

There is also a discussion of timeout period of up to 4 minutes in this thread. That has been fixed and you should be able to logout and login to compute nodes without a lag. If you type devcloud_login -help you will see instructions on using batch mode, the preferred method of launching jobs.

 

Larry

 

 

Reply