Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
674 Discussions

Help with using I/O channels in OpenCL

JSell4
Beginner
1,577 Views

board_spec.PNGled_controller_v.PNGsystem_qsys.PNGtop.v.PNGI'm having issues using IO channels in OpenCL using the DE1SOC board from Terasic, I've modified the BSP and added in a basic LED controller to test it but still cannot make the LED light up, here is a list of files i've modified.

 

  • I've modified the system.qsys to include the controller and hooked up the clk and reset signals to the kernel, along with exporting the output so that it can be attached in the top.v file.
  • I've added the IO interface to the board.xml file so that it can correctly detect where to output the channel data to.
  • I've modified the top.v and .qsf file so that the led_controller output is connected to the right pin

I'm attaching the picture of the places where I've modified the original bsp files and including the verilog model of the led_controller.

0 Kudos
4 Replies
JSell4
Beginner
1,108 Views

Any help would be greatly appreciated, I'm relatively new to this.

0 Kudos
Fawaz_Al-Jubori
Employee
1,108 Views
Hello, Kindly allow me some time to investigate about this request thanks
0 Kudos
JSell4
Beginner
1,108 Views

poke

0 Kudos
Fawaz_Al-Jubori
Employee
1,108 Views

Hello,

Did you try hooking led_in to a direct switch and make sure rest of the circuit works fine and the LED lights up successfully?

Once you have confirmed this, how are you connecting the led_in[0] to the AVST intf generated by the compiler? Is it connect to the valid or the databus.

 

Thanks

0 Kudos
Reply