Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
681 Discussions

Issues when running ONEAPI devcloud FPGA Hardwares

Wei-Chih
Novice
550 Views

Hello Intel ONEAPI devcloud

 

I meet some issues when i run my code on devcloud jupyter using fpga hardware. (follow this website tutorial:  https://devcloud.intel.com/oneapi/documentation/base-toolkit/)

 

I can run my code by using GPU and FPGA emulator but when I tried to run FPGA hardware node it will get errors as below:

 

for arria10 error :
terminate called after throwing an instance of 'cl::sycl::runtime_error'
what(): Native API failed. Native API returns: -42 (CL_INVALID_BINARY) -42 (CL_INVALID_BINARY)
make: *** [run_fpga_hardware] Aborted

for stratix10 error:
terminate called after throwing an instance of 'cl::sycl::nd_range_error'
what(): Non-uniform work-groups are not supported by the target device -54 (CL_INVALID_WORK_GROUP

 

WeiChih_0-1657214849943.png

 

WeiChih_1-1657214875041.png

 

 

 

Do you know what are the problems and  how can I modify my code?

 

 

thanks

0 Kudos
1 Reply
Kenny_Tan
Moderator
516 Views

Hi,


Thanks for using Intel community forum,


Kindly expect some delay in the reply due to holiday.


Thanks,


0 Kudos
Reply