Intel® High Level Design
Support for Intel® High Level Synthesis Compiler, DSP Builder, OneAPI for Intel® FPGAs, Intel® FPGA SDK for OpenCL™
677 Discussions

Unable to detect device using 'aocl diagnose' command

bear005
Beginner
981 Views

I'm using an Arria10 FPGA for OpenCL development and currently
1. The FPGA has been inserted into the server
2. The SDK of Opencl for fpga has been downloaded
3. The corresponding BSP tool has been downloaded
Then I started to operate according to the documentation, but when I use the command 'aocl diagnose', it shows that no device is detected, I want to ask what could be the cause of the problem? Or for FPGA devices, in addition to downloading the SDK, do you need to install other drivers or software?

0 Kudos
6 Replies
HRZ
Valued Contributor III
963 Views

Have you installed the SDK (which also installs the necessary drivers) and programmed the FPGA with a valid firmware to enable the PCI-E core? The following document covers all necessary steps:

 

https://cdrdv2.intel.com/v1/dl/getContent/709277?fileName=aocl_getting_started-683188-709277.pdf

0 Kudos
bear005
Beginner
952 Views

thanks, after I read the link you provided, I see what is in the picture. Does this mean that I plugged the FPGA directly into the server, and the problem that the OpenCL platform cannot be detected is that I didn't find a technician to configure the environment?

2271646016741_.pic.jpg

0 Kudos
HRZ
Valued Contributor III
938 Views

What is the exact model of the board you are using? If you are using a supported board which comes with an OpenCL BSP, you should be able to set it up yourself by following the documentation.

0 Kudos
BoonBengT_Intel
Moderator
914 Views

Hi @bear005,

Thank you for posting in Intel community forum, hope all is well and apologies for the delayed in response.
Following up on the queries, did you managed to get the queries attended? Please do let us know if the doubts/clarification are still open, and we would try our best to clarify.

Best Wishes
BB

0 Kudos
bear005
Beginner
908 Views

Thanks, at present I am going to reinstall the operating system to install the SDK, and configure it according to the guidance of the documentation, if I still encounter problems, I will come back to the community for help

0 Kudos
BoonBengT_Intel
Moderator
851 Views

Hi @bear005,

 

Thanks and noted on the updates, as we do not receive any further clarification, we would assume challenge are resolved. Hence thread will no longer be monitored. For new queries, please feel free to open a new thread and we will be right with you. Pleasure having you here.

Best Wishes
BB

0 Kudos
Reply