Community
cancel
Showing results for 
Search instead for 
Did you mean: 
bingbing_l_
Beginner
554 Views

VS2015 + SDE Debugger

Hi,

I'm attempting to debug an application via Visual Studio 2015 which has the SDE Debugger.

System:

  • Windows 7
  • Visual Studio 2015
  • sde-msvs2015-3.0.2.msi
  • sde-external-7.41.0-2016-03-03-win

I've setup the SDE path and have an empty project and selected the SDE Debugger, the Application Command and Working Directory are correct. It appears that the debugger never connects properly, I will see the SDE command window popup (with nothing printed). Visual Studio will eventually show a dialog:

"Not able to connect with the debugger after 20 seconds. Try increasing the '20 Timeout' property. This could also indicate that the Pin tool crashed in its main() function."

Even bumping the timeout to 60 seconds doesn't seem to work.

I have tried all the methods in this forum, but it still doesn't work. 

I feel very worried now, I hope you can give me your help!

Thank you very much!!!

0 Kudos
19 Replies
MICHAEL_G_Intel1
Employee
554 Views

Hi

This usually means that something went wrong In the configuration.

1. Verify that  the "SDE Kit Directory" is specified under:  Debug -> Options and Settings ... -> Intel(R) SDE debugger

2. Have you installed the latest version of plugin? (version 3.0.2)?

Regards,

Michael

bingbing_l_
Beginner
554 Views

Hi

Thank you very much for your timely reply!!!

1. "SDE Kit Directory" is set as shown in the attachment.

2. I have installed the latest version of plugin-------"sde-msvs2015-

3.0.2.msi", if I have not installed the latest version of plugin, the 

" Intel(R) SDE debugger----SDE Kit Directory"   and the "SDE Debugger" 

do not appear at all in the VS2015.

        System:

Windows 7
Visual Studio 2015
sde-msvs2015-3.0.2.msi
sde-external-7.41.0-2016-03-03-win


Thank you very much!!!

MICHAEL_G_Intel1
Employee
554 Views

Hi

Did you install update 2 of visual studio 2015?

https://www.visualstudio.com/en-us/news/vs2015-update2-vs.aspx

If not then please install it and then uninstall and install SDE VS plugin again.

Regards,

Michael

MICHAEL_G_Intel1
Employee
554 Views

bingbing_l_
Beginner
554 Views

Hi

Thank you very much for your timely reply!!!

1.I had installed  the update 2 of visual studio 2015 , then uninstalled and installed SDE VS plugin again acording to your method.

when I debugging a simple project, it still appears that the debugger never connects properly, I will see the SDE command window popup (with nothing printed). Visual Studio will eventually show a dialog:

"Not able to connect with the debugger after 20 seconds. Try increasing the '20 Timeout' property. This could also indicate that the Pin tool crashed in its main() function."

2. I want to know What options do you choose when you install VS2015 in the second attachment called "how_to_choose_options.png", and if I missed some options, it will appears that the debugger never connects properly as above.

Thank you very much!!!

 

 

bingbing_l_
Beginner
554 Views

Hi

I hope the following information will help you:

I had made the "sde.exe" to debug "HelloWorld.exe" directly , the "sde.exe" can debug successfully as shown in the attachment.

MICHAEL_G_Intel1
Employee
554 Views

Hi

Can you please try and work with the solution I have uploaded.?

All you need to do is to replace the location of the application exe file and sde.exe

Regards,

Michael504338

bingbing_l_
Beginner
554 Views

Hi 

I had try and work with the solution which is called "SDEDBG" you have uploaded. My settings are set as follows:

1.the location of the application exe file is shown in attachment 1--5.

2.the location of sde.exe is shown in attachment 6.

Please make sure that the settings I had set as shown in the attachments are correct.

 

MICHAEL_G_Intel1
Employee
554 Views

Hi

I saw that you are setting 32bits application in the VS

Is the application 32 or 64 bits?

You need to set SDE debugger both for 64 and 32 bits.

I would like you to modify only 2 things from my solution:

1. The sde kit location

2. The application command line

No need to modify anything else or build the sources. Just try to modify the 2 things and press F5

Regards,

Michael

bingbing_l_
Beginner
554 Views

Hi

Thank you very much!!!

I had  modified only 2 things from your solution--"SDEDEG.sln" as you had asked

1. The sde kit location as shown in attachment " SDK_Kit_Dir.png "

2. The application command line as shown in  attachment "application_command_line.png ".

 I had not modified anything else or build the sources. I just modifified the 2 things and press F5

3. When I want to set debugger for 64 bits firstly, I found that the VS2015 didn't display "SDE Debugger" as shown in attachment "  x64__firstly_debug_F5.png". Then I press F5, the result is shown in attachment " x64_firstly_Output_Error ".

4.When I want to set debugger for 32 bits secondly, I found that the VS2015 display normal as shown in attachment "  x86_SDE-Debugger_Secondly_debug_F5.png". Then I press F5, the result is shown in attachment " x86_secondly_Output".

Please make sure that the settings I had set as shown in the attachments are correct.

Regards,

Liu Bingbing

MICHAEL_G_Intel1
Employee
554 Views

Hi

As I wrote to you before.

Please do not try and compile the source.!!!!!

You did something wrong.

Please do the following  :

1. Copy again my solution

2. Replace the location of sde kit.

3. Replace the application command line with your application command line.

4. If your application is 64 bits then set 64 bits debugger

5. If your application is 32bits then set 32bits debugger

6. Why are you using version 7.36? there is already sde version 7.41.

Regards,

Michael

bingbing_l_
Beginner
554 Views

Hi

I had just done according to these 6 aspects, cleanly shown in the attachments.

Then I press ''F5“, the VS2015 would generated the project and displayed the error window. In this process, the program will be compiled.

Now I am feeling very confused that I couldn't know what you want me to do, and I felt your description is too simple so that I done some 

things wrong easily. Would you please show the process of operation in VS2015 through the image ? 

I felt very worried that I had been dealing with this problem for a long time !

Thank you very much for your help !

            Regards,

            Liu Bingbing

MICHAEL_G_Intel1
Employee
554 Views

Hi

1. You should not recompile . VS asks you if it should compile and you need to answer "no".

2. The application command line is not were you showed me is not what I am talking about. attached is what I mean.vs-app-cmd.JPG

bingbing_l_
Beginner
554 Views

Hi

1.My reset is shown in the attachments.

2.Then I press "F5", and I press "NO". Besides, I didn't press any key.

3.The result is shown in attachments.

Please make sure that the settings which I had set as shown in the attachments are correct.

Thank you very much for your help !

            Regards,

            Liu Bingbing

jan_v_
New Contributor I
554 Views

I got a different problem with debugging SDE + VS 2015.

For the integration I used sde-msvs2015-3.0.2.msi.

The SDE is sde-external-7.49.0-2016-07-07-win.

I correctly set the path for the SDE Kit Directory.

When trying to SDE debug I get the error box Unable to start debugging as shown below.

What can be the problem ?

vs.pngerror.png

MICHAEL_G_Intel1
Employee
554 Views

Hi

It seems that you did not configure the debugger in VS to be SDE debugger.

Regards,

Michael

MICHAEL_G_Intel1
Employee
554 Views

this is how you need to set debugger

jan_v_
New Contributor I
554 Views

Sure, I did set the debugger to SDE debug.

Else it would use the normal VS debug and not show an error box.

jan_v_
New Contributor I
554 Views

Got code running anyway, who needs a debugger.

Interesting to see that the Cannonlake emulation support AVX512 as expected.

Can't wait to test on the real thing.

 

Reply