Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Genady_Malinsky
Beginner
80 Views

Can't build Intel® IPP 7.1 Samples

Hi,

I download the new Intel IPP 7.1 and ipp-samples.7.1.1.013 also I download CMake* 2.8.8 and  ActiveState* perl.

My OS is Win7  32 bit i5.

When I tried to compile the audio-video-codecs I encountered an Error:

C:\IPP 7.1.1\ipp-samples.7.1.1.013\builder>perl build.pl --cmake=audio-video-cod
ecs,ia32,vc2010,s,st,release
CNot searching for unused variables given on the command line.
Make Error: The source directory "C:/IPP 7.1.1/ipp-samples.7.1.1.013/__cmake/audio-video-codecs.ia32.vc2010.s.st/7.1.1/ipp-samples.7.1.1.013/sources/audio-video-codecs" does not exist.
Specify --help for usage, or press the help button on the CMake GUI.

Can someone please assist?

Thanks,

Genady.

0 Kudos
5 Replies
Ying_H_Intel
Employee
80 Views

Hi Genady, I upload the project you asked by premier. Just a quick idea, the directory structure seems do a trick. How about keep the initial structure: l C:\IPP 7.1.1\w_ipp-samples_p_7.1.1.013\ipp-samples.7.1.1.013\builder ? Best Regards, Ying
Sergey_K_Intel
Employee
80 Views

Hi Genady, Please, make sure that there are no spaces in directory names. Buil.pl doesn't like them. Regards, Sergey
Ying_H_Intel
Employee
80 Views

upload the two msvc2010 projects with the post. As the project is using absolute path, please 1) create a directory under C: C:\Temp. 2) extract w_ipp-samples_p_7.1.1.013 there. The directory structure is like C:\Temp\w_ipp-samples_p_7.1.1.013\ipp-samples.7.1.1.013 3) extract the __cmake.zip C:\Temp\w_ipp-samples_p_7.1.1.013\ipp-samples.7.1.1.013\__cmake

Serhat_T_
Beginner
80 Views

Hi,

I cannot create VS 2010 solution with cmake. 

Folder: /ipp-samples.7.1.1.013/sources/image-processing/application/ippidemo 

It gives this error:

CMake Error at CMakeLists.txt:20 (make_executable):

Unknown CMake command "make_executable".

Anton_S_Intel
Employee
80 Views

Hi,

Genady, please make sure that you have no spaces in paths. This is know issue and will be fixed.
Serhat, can you please upload full log of build.pl run? You should run command like "build.pl -cmake=..... > log.txt 2>&1"

Reply