Intel® Integrated Performance Primitives
Community support and discussions relating to developing high-performance vision, signal, security, and storage applications.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.

DXVideoRender window is topmost

andrei_m
Beginner
148 Views

Hi,

I'm having strange issue, the video playback window is always on top, even if the window is not visible it still stays on top and I'm not using fullscreen option.
I have tried creting the window for DXVideoRender with HWND_NOTOPMOST, but it does not help.

Does anyone know how to disable TOPMOST feature?

Thanks in advance,
Andrei.

0 Kudos
1 Solution
hsunnet
Novice
148 Views
Quoting - andrei.m

Hi,

I'm having strange issue, the video playback window is always on top, even if the window is not visible it still stays on top and I'm not using fullscreen option.
I have tried creting the window for DXVideoRender with HWND_NOTOPMOST, but it does not help.

Does anyone know how to disable TOPMOST feature?

Thanks in advance,
Andrei.

An alternative way is to use BLT render instead. This render has similar performance as DX render and it is not on top of applications Z-buffer.

View solution in original post

2 Replies
hsunnet
Novice
149 Views
Quoting - andrei.m

Hi,

I'm having strange issue, the video playback window is always on top, even if the window is not visible it still stays on top and I'm not using fullscreen option.
I have tried creting the window for DXVideoRender with HWND_NOTOPMOST, but it does not help.

Does anyone know how to disable TOPMOST feature?

Thanks in advance,
Andrei.

An alternative way is to use BLT render instead. This render has similar performance as DX render and it is not on top of applications Z-buffer.

andrei_m
Beginner
148 Views
Quoting - hsunnet

An alternative way is to use BLT render instead. This render has similar performance as DX render and it is not on top of applications Z-buffer.

Hi hsunnet,

Thanks, switching to BLT render solved my problem. I had to take it from 5.3 version, because unfortunately it is removed from 6.0.

Andrei.

Reply