Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
264 Views

LNK 1104 Cannot open file "ippCore.lib"

Hello,

I'm a programming and C++ beginner so I apologize for my confusion.

I have windows 10, Intel IPP 2020 Update 1 installed, Visual Studio 2019. My compiler is local windows debugger(I think...I'm trying to follow forum detalis for question posting). I am trying to use old image processing code. Some of the IPP libraries it uses are out of date. Accordingly, I installed Intel legacy libraries here  ( https://software.intel.com/content/www/us/en/develop/articles/intel-ipp-legacy-libraries.html ). The compiler produced errors, saying that libraries like ippm.lib could not be opened (LNK 1104). I clicked on the project, click on properties, go to linker and change the name of the additional dependency from ippm90lgc.lib. This would get rid of the error. Here is the problem, it is unclear which .lib file replaces the ippCore.lib as none follow the naming format (ippCore90lgc.lib does not seem to exist).

Note: some additional changes I made were adding #include "ipps90legacy.h" and
#include "ipps90legacy_redef.h" among other #include's at the top of all source files,in VC++ directories I added legacie's include folder to include directories and lib folder to library directories. These steps were following the directions in the readme.txt file in the ipp legacy download. 

#if !defined( __STDCALL )
#define __STDCALL IPP_STDCALL 
#endif

to one of the .cc files. This was following the recommendations of a forum user here ( https://software.intel.com/en-us/forums/intel-integrated-performance-primitives/topic/779883 ). It successfully got rid of the error. 

If I need to add more information please let me know. Any help is much appreciated.

Thanks

 

0 Kudos
3 Replies
Highlighted
Employee
264 Views

Hi Colton,

There is no ippcore library in legacy package. You should use "ippcoremt.lib" from IPP 2020.

Regards,
Sergey

0 Kudos
Highlighted
264 Views

Thank you very much

Colton

0 Kudos
Highlighted
260 Views

Hello Again,

I have an update. I used the ippmcoremt.lib as instructed. I am now getting 29 errors. All are either LNK 2001 or LNK 2019 "unresolved external symbols"(see attached photo). I also will attach a photo of all the .lib files I added to the properties->Linker->input->additional dependencies section. I hope this information is sufficient for diagnosing my problem. If not I apologize and let me know what I need to add.

Thanks Again

Colton 

0 Kudos