Showing results for 
Search instead for 
Did you mean: 
New Contributor II

2.8 inch Adafruit TFT screen (linux support)

Hi all,

Has anyone got success with Adafruit TFT screen( 2.8 TFT Touch Shield for Arduino with Resistive Touch Screen ID: 1651 - $34.95 : Adafruit Industries, Unique & fun DIY e…) on Galileo (through Linux not Arduino IDE). I have built a new image with fbtft drivers following /message/225212# 225212 225212 (till step 6) .

But I have following 2 questions:

2) How do I install xorg packages on my LSB image created above? Can I install using opkg? or do I have to include it during image building in yocto?

2) How do I test my TFT screenwith linux on galileo? Can anyone share a testcase if possible?



6 Replies
Valued Contributor III

The answer Is I am not sure... I have it running on Edisons, both with Arduino IDE and with my own libraries. More details on the thread:

In particular code for Edison on Arduino IDE is up at:

Code for running it native with linux is part of my Raspberry pi project: KurtE/Raspberry_Pi · GitHub

Again this if for Edison, but not sure what if anything would change as using MRAA SPI and GPIO to talk to device.

Community Manager

Hi Paridhi,

It has been quite a while since I worked with that screen last. Just a warning that it was a gen 1 Galileo and early firmware. I expect nothing substantial has changed but I haven't tried it with anything newer. Gen 2 Galileo is interesting with the native-IO it may actually be easier and run better.

I no longer have access to my Linux VM that I was using, the file system got corrupted somehow. But from looking at my notes, I was manually editing files to include whatever packages I needed. So I included xorg by editing a config file before building the image rather than while running the image. It looks like I was editing the ".bb" file and adding new entries under IMAGE_INSTALL. To know the exact names to include, I ran the hob command (available after you setup a build environment) and poked around in the GUI exploring the available packages. I wouldn't be surprised to find out there is a better way but that is what I did.

The first thing I did to test it was run xclock. A nice, lightweight program that I didn't have to wait to start up. GIMP was fun too but way too slow. The tricky thing with testing it is it pretty much either works or doesn't. I did a lot of work with my logic analyzer looking at SPI data. I didn't have to debug the SPI data but it was easy to get a pin number wrong, set a mux to the wrong value, etc.

Best of luck on getting it running. It was a lot of frustration working on it but it really was cool to see a Linux GUI running on a board designed to be headless. I will help out if I can.


New Contributor II

Thanks KurtE.

Hi dferyance .. I am struggling with Gen1 .. I have added the fbtft drivers to my image but seems I need xorg to get fbtft running. I shall ping you back as and when I proceed




Hi Paridhi_Agrawal;

Were you able to install the xorg packages and get your TFT screen working?



New Contributor II

Hi CMata_Intel,

My Galileo has stopped responding(needs firmaware recovery). So I am working on fixing it. Will get back when I am through.




Hi Paridhi_Agrawal,

I tried to do the same thing, but I didn't have success with the galileo. So I got an arduino mega to be the slave of the galileo.

On galileo I'm using Yocto , and to send the data I'm using UART with MRAA lib. This Git helped me a lot!

On Arduino, I'm using the serial port to receive the data, and it is very simple.

I hope I've helped you.