Community
cancel
Showing results for 
Search instead for 
Did you mean: 
amars6
Novice
1,508 Views

3G / 4G LTE in edison's OTG (HiLink Huawei E3131)

Hello, I want to use a USB internet modem. I have the Huawei E3131 with HiLink. I used it with the raspberry pi, and only thing that I have to configure is switch the mass storage vendor/product ID to the modem ID and then it apears as eth1 if I call ifconfig. In edison is not the same, because I have switched to modem interface, and no new network interface shows.

I followed this tutorial in raspberry and works like a cham: https://www.raspberrypi.org/forums/viewtopic.php?t=18996 https://www.raspberrypi.org/forums/viewtopic.php?t=18996

https://www.raspberrypi.org/forums/viewtopic.php?t=18996 Raspberry Pi • View topic - Huawei E3131 on Wheezy

Also works install standalone usb_modeswitch, and then I got the new network interface eth1. In raspbian.

I don't know why in edison I cant get the network interface, HiLink works perfect in raspbian, but either Yocto and Ubilinux is not showing the new interface.

How can I get working?

Thanks

0 Kudos
2 Replies
idata
Community Manager
161 Views

Hello amarsa,

 

 

Thank you for your interest in the Intel® Edison Breakout Board.

 

 

In order to enable USB modem support, you'll need to build a custom Yocto Linux image. I suggest you to read this article:

 

 

Building Yocto Linux for Intel Edison with 3G USB modems support

 

https://bovs.org/post/168/Building-Yocto-linux-for-Intel-Edison-with-3G-USB-modems-support

 

 

There are also a couple of threads that may help you get a better understanding of the details of enabling USB modems support:

 

 

SSH access to edison connected via mobile internet 3g

 

https://communities.intel.com/message/441835# 441835 https://communities.intel.com/message/441835# 441835

 

 

Need 3G connection on Arduino board with Huawei E171

 

https://communities.intel.com/thread/101585 https://communities.intel.com/thread/101585

 

 

If you have any other question, don't hesitate to contact us.

 

 

Have a nice day.

 

 

Regards,

 

Andres V.
amars6
Novice
161 Views

Hello,

Building a custom image to that problem is like kill a mosquito with a rifle...

I get it working disablink HiLink, which was the element that has incompatibility ( i think cdc_ether was the missing packet). In raspberry works perfectly so would be a good point to add this compatibility easy.

Disable huawei hilink: https://zedt.eu/tech/hardware/switch-huawei-e3131-hilink-modem-mode/ https://zedt.eu/tech/hardware/switch-huawei-e3131-hilink-modem-mode/

Then i configurated the modem with umtskeeper (which include Sakis3g)

http://mintakaconciencia.net/squares/umtskeeper/ UMTSkeeper internet keep-online

The same process like a raspberry, plenty of tutorials on the internet.

I run the " $ sakis3g --interactive" command, and perfect.

This solution was using debian Ubilinux, more easy than yocto. I think that only support yocto is a mistake..

Reply