Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,441 Views

5 GHz AP with Intel Edison

Jump to solution

Hello all,

I have a question regarding 5 GHz AP mode for Intel Edison. I use the Yocto source "iot-devkit-yp-poky-edison-20160606" from Intel.

Is there any other possibility to configure the regulatory domain then using CRDA (It is not possible to build CRDA with the given Yocto sources from above see for more information) or compiling a new kernel for every country?

In which file is the standard regulatory domain set? Or is it hard coded to the kernel? Only setting the regulatory domain in hostapd.conf is not enough.

Best

Nils

Tags (2)
1 Solution
idata
Community Manager
44 Views

Hi nilson,

 

 

Thank you for contacting us. The CRDA information, as you stated, seems to be hardcoded into the kernel. Just by looking at iot-devkit-yp-poky-edison-20160606 we couldn't find any information that would allow to configure the regulatory domain. Building an image with the necessary packages seems the best way to approach this problem. I looked at the thread you mentioned /thread/111535 https://communities.intel.com/thread/111535 and noticed you didn't continue with troubleshooting. I'd recommend you to answer the questions you were asked in that thread, so we know more about how you build the image. This will help us have an idea of what went wrong and help us provide a suggestion.

 

 

Regards,

 

-Sergio A

 

View solution in original post

3 Replies
idata
Community Manager
45 Views

Hi nilson,

 

 

Thank you for contacting us. The CRDA information, as you stated, seems to be hardcoded into the kernel. Just by looking at iot-devkit-yp-poky-edison-20160606 we couldn't find any information that would allow to configure the regulatory domain. Building an image with the necessary packages seems the best way to approach this problem. I looked at the thread you mentioned /thread/111535 https://communities.intel.com/thread/111535 and noticed you didn't continue with troubleshooting. I'd recommend you to answer the questions you were asked in that thread, so we know more about how you build the image. This will help us have an idea of what went wrong and help us provide a suggestion.

 

 

Regards,

 

-Sergio A

 

View solution in original post

idata
Community Manager
44 Views

Hello Sergio A,

Thank you for your reply. I added the host machine setting to the threads.

I started the build process with fresh sources (iot-devkit-yp-poky-edison-20160606) again, to give a detailed description how I build the image. Unfortunately the sources don't build any longer. See thread .

At the moment I search for new sources that work or a simple patch.

Do you have any idea?

Best

Nils

idata
Community Manager
44 Views

Hi

 

 

Thank you for your reply. We already saw the reply with the steps you followed for the build. We'll start working on that case and post a suggestion for you soon. Since this question is closely related to the one in your other thread, we'll continue to help you here: /thread/111630 https://communities.intel.com/thread/111630 , to avoid having multiple threads with the same question and to avoid confusion.

 

 

Thank you for your understanding.

 

 

-Sergio A

 

Reply