Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SZ2
New Contributor I
1,081 Views

A2DP profile missing on the Intel Edison

Greetings.

I try to connect to some bluetooth speakers from my Intel Edison module. I can pair, but when I try to connect through bluetoothctl I get an error:

[bluetooth]# connect XX:XX:XX:XX:XX:XX

Attempting to connect to XX:XX:XX:XX:XX:XX

Failed to connect: org.bluez.Error.Failed

Running the command systemctl status -l bluetooth provided some more information:

a2dp-sink profile connect failed for XX:XX:XX:XX:XX:XX: Protocol not available

I did some searching online and I found out that other distributions have had problems with that the pulseaudio-module-bluetooth is missing. How do I proceed on the Intel Edison module? Do I need to download any sources and build? Or is there any package manager present that can download the missing packages?

Also, running opkg list-installed | grep pulseaudio produced:

pulseaudio-lib-alsa-util - 6.0-r0

pulseaudio-lib-bluez5-util - 6.0-r0

pulseaudio-lib-cli - 6.0-r0

pulseaudio-lib-protocol-cli - 6.0-r0

pulseaudio-lib-protocol-native - 6.0-r0

pulseaudio-misc - 6.0-r0

pulseaudio-module-alsa-card - 6.0-r0

pulseaudio-module-alsa-sink - 6.0-r0

pulseaudio-module-alsa-source - 6.0-r0

pulseaudio-module-always-sink - 6.0-r0

pulseaudio-module-augment-properties - 6.0-r0

pulseaudio-module-bluetooth-policy - 6.0-r0

pulseaudio-module-bluez5-device - 6.0-r0

pulseaudio-module-bluez5-discover - 6.0-r0

pulseaudio-module-card-restore - 6.0-r0

pulseaudio-module-cli-protocol-unix - 6.0-r0

pulseaudio-module-console-kit - 6.0-r0

pulseaudio-module-default-device-restore - 6.0-r0

pulseaudio-module-detect - 6.0-r0

pulseaudio-module-device-restore - 6.0-r0

pulseaudio-module-filter-apply - 6.0-r0

pulseaudio-module-filter-heuristics - 6.0-r0

pulseaudio-module-intended-roles - 6.0-r0

pulseaudio-module-loopback - 6.0-r0

pulseaudio-module-native-protocol-unix - 6.0-r0

pulseaudio-module-null-sink - 6.0-r0

pulseaudio-module-position-event-sounds - 6.0-r0

pulseaudio-module-rescue-streams - 6.0-r0

pulseaudio-module-role-cork - 6.0-r0

pulseaudio-module-stream-restore - 6.0-r0

pulseaudio-module-suspend-on-idle - 6.0-r0

pulseaudio-module-switch-on-port-available - 6.0-r0

pulseaudio-module-udev-detect - 6.0-r0

pulseaudio-server - 6.0-r0

pulseaudio-service - 1.0-r0

Note that I do not have the pulseaudio-module-bluetooth, only pulseaudio-module-bluetooth-policy. Are these packages different?

6 Replies
idata
Community Manager
98 Views

Hi zettez,

 

 

The first thing that comes to mind as the issue is the image you're using. I'm running a fresh install of the latest image and running the command systemctl status -l Bluetooth provided the following output:

 

 

systemctl status -l bluetooth

 

● bluetooth.service - Bluetooth service

 

Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)

 

Active: active (running) since Tue 2016-10-04 20:59:38 UTC; 16h ago

 

Docs: man:bluetoothd(8)

 

Main PID: 242 (bluetoothd)

 

Status: "Running"

 

CGroup: /system.slice/bluetooth.service

 

└─242 /usr/lib/bluez5/bluetooth/bluetoothd -E

 

Oct 04 20:59:37 TQFGOD bluetoothd[242]: Bluetooth daemon 5.37

 

Oct 04 20:59:37 TQFGOD bluetoothd[242]: Starting SDP server

 

Oct 04 20:59:37 TQFGOD bluetoothd[242]: Bluetooth management interface 1.3 initi alized

 

Oct 04 20:59:38 TQFGOD systemd[1]: Started Bluetooth service.

 

 

I also ran the opkg list-installed | grep pulseaudio and the outputs are the same, so no need to modify anything here. Before attempting to run connect on the Bluetooth command line there's a few commands you need to do. I'd suggest you to flash the latest image, where the output of cat /etc/version is 201606061707 and follow section 6.3 of the Bluetooth guide here http://www.intel.com/content/www/us/en/support/boards-and-kits/000005743.html http://www.intel.com/content/www/us/en/support/boards-and-kits/000005743.html .

 

 

If you still have issues after running the connect command please post screenshots of the output of each of the steps of section 6.3 of the Bluetooth guide.

 

 

We'll be waiting for your response.

 

 

-Sergio

 

SZ2
New Contributor I
98 Views

Hey Sergio.

Running cat /etc/version gave me:

So I am running the latest. I will post the screenshots of the 6.3 section in the guide.

I removed all my paired devices and rebooted the system, then when running systemctl status -l bluetooth I got the following (note that I have errors while you do not seem to have it):

This is a screenshot of when I scan and pair with my bluetooth speaker, along the connection problem.

This is a screenshot of when I print the status of the bluetooth, notice the last new line which I mentioned in my earlier post (potocol not found):

This is a screenshot of my sinks (the first one is the dummy, partially visible, the other is something else default):

I could try to re-flash it but I do not see the point as we are running the same version. It clearly says that a protocol is missing, is this something I have to install by myself or is this actually bundled in the image? I tried this approach on three different speakers, the one used in the examples are the target speakers to use. Bluetooth works otherwise, I can send data between my Edison module and my phone, I can scan for beacons, but I cannot use the A2DP.

idata
Community Manager
98 Views

Thank you for attaching the screenshots we requested. Can you send us the output of the command opkg list-installed| grep bluez. This command will show which bluez version you have installed. I'm using:

 

 opkg list-installed |grep bluez

 

bluez5 - 5.37-r0

 

bluez5-dev - 5.37-r0

 

bluez5-obex - 5.37-r0

 

pulseaudio-lib-bluez5-util - 6.0-r0

 

pulseaudio-module-bluez5-device - 6.0-r0

 

pulseaudio-module-bluez5-discover - 6.0-r0

 

 

You can try to restart the service with systemctl restart -l Bluetooth and try again to see the status? Even though we both are using the same image there might be some files that are incorrectly configured since you're seeing those errors. A fresh image install will help fix those issues and get the proper default configuration running.

 

 

Let us know your results.

 

 

-Sergio

 

SZ2
New Contributor I
98 Views

Hey!

Running the command gave me:

root@edison:~# opkg list-installed| grep bluez

bluez5 - 5.37-r0

bluez5-dev - 5.37-r0

bluez5-obex - 5.37-r0

pulseaudio-lib-bluez5-util - 6.0-r0

pulseaudio-module-bluez5-device - 6.0-r0

pulseaudio-module-bluez5-discover - 6.0-r0

Interesting though, I have found I have both bluez-5.24 and bluez-5.41 unzipped, maybe I installed any of these and screwed up the already installed bluez? I will try to do a fresh install now, maybe it is just me having multiple versions installed messing with each other.

I will reply when I have tested a fresh install.

SZ2
New Contributor I
98 Views

Alright so after a fresh install everything works. I must have installed another version that interfered with the original. I still have other stuff to set up (because of the re-flash everything else was removed), if I have problems after that then I will write again, and tell you what I installed. Otherwise everything worked out.

Thanks!

idata
Community Manager
98 Views

Thank you for letting us know a fresh image install solved this issue. If you have any other issues don't hesitate to contact us again.

 

 

-Sergio

 

Reply