Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,055 Views

Arduino IDE error on Fedora 23

Jump to solution

I followed this guide https://software.intel.com/en-us/get-started-arduino-install# Linux IoT - Installing the Arduino* IDE | Intel® Developer Zone but when i installed the new boards with the boards manager i get this in console

=========================================================================================================

[root@localhost ~]# /home/lewatoto/arduino-1.6.7/arduino

Picked up JAVA_TOOL_OPTIONS:

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/etc/ld.so.cache links to an absolute path /etc/ld.so.cache

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/libexec/i586-poky-linux-uclibc/gcc/i586-poky-linux-uclibc/4.7.2/ranlib links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-ranlib

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/libexec/i586-poky-linux-uclibc/gcc/i586-poky-linux-uclibc/4.7.2/nm links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-nm

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/libexec/i586-poky-linux-uclibc/gcc/i586-poky-linux-uclibc/4.7.2/strip links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-strip

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/libexec/i586-poky-linux-uclibc/gcc/i586-poky-linux-uclibc/4.7.2/cpp links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-cpp

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/libexec/i586-poky-linux-uclibc/gcc/i586-poky-linux-uclibc/4.7.2/ar links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-ar

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/libexec/i586-poky-linux-uclibc/gcc/i586-poky-linux-uclibc/4.7.2/objcopy links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-objcopy

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/libexec/i586-poky-linux-uclibc/gcc/i586-poky-linux-uclibc/4.7.2/gcc links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-gcc

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/libexec/i586-poky-linux-uclibc/gcc/i586-poky-linux-uclibc/4.7.2/objdump links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-objdump

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/libexec/i586-poky-linux-uclibc/gcc/i586-poky-linux-uclibc/4.7.2/ld links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-ld

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/libexec/i586-poky-linux-uclibc/gcc/i586-poky-linux-uclibc/4.7.2/as links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-as

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/i586-poky-linux-uclibc/opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/opkg links to an absolute path /opt/clanton-tiny/1.4.4/sysroots/x86_64-pokysdk-linux/usr/bin/opkg-cl

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/i586-poky-linux-uclibc/usr/src/debug/libgcc/4.7.2-r20/build/libgcc/gthr-default.h links to an absolute path /jenkins_builder/workspace/GLLO_1.0.5-Toolchain-Linux64/yocto_build/tmp/work-shared/gcc-4.7.2-r20/gcc-4.7.2/libgcc/gthr-posix.h

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/i586-poky-linux-uclibc/usr/src/debug/libgcc/4.7.2-r20/build/libgcc/unwind.h links to an absolute path /jenkins_builder/workspace/GLLO_1.0.5-Toolchain-Linux64/yocto_build/tmp/work-shared/gcc-4.7.2-r20/gcc-4.7.2/libgcc/unwind-generic.h

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/i586-poky-linux-uclibc/usr/src/debug/libgcc/4.7.2-r20/build/libgcc/enable-execute-stack.c links to an absolute path /jenkins_builder/workspace/GLLO_1.0.5-Toolchain-Linux64/yocto_build/tmp/work-shared/gcc-4.7.2-r20/gcc-4.7.2/libgcc/enable-execute-stack-empty.c

Warning: file /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/i586-poky-linux-uclibc/usr/src/debug/libgcc/4.7.2-r20/build/libgcc/md-unwind-support.h links to an absolute path /jenkins_builder/workspace/GLLO_1.0.5-Toolchain-Linux64/yocto_build/tmp/work-shared/gcc-4.7.2-r20/gcc-4.7.2/libgcc/config/i386/linux-unwind.h

Setting it up.../tmp/tmp.N08iurxII6/relocate_sdk.sh /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/relocate_sdk.sh

SDK could not be set up. Relocate script failed. Abort!

find: invalid mode '+111'

=========================================================================================================

i found this solution for the "find: invalid mode '+111'" error when i run the install_script.sh

=========================================================================================================

[root@localhost ~]# .arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/install_script.sh

Setting it up.../tmp/tmp.sZeLSYMvkD/relocate_sdk.sh /root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/relocate_sdk.sh

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/raw2flash.akita

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/raw2flash.borzoi

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/perl.real

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/raw2flash.terrier

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/flash2raw.terrier

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/python

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/python-config

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/flash2raw.borzoi

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/python2-config

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/flash2raw.akita

link:/root/.arduino15/packages/Intel/tools/i586-poky-linux-uclibc/1.6.2+1.0/i586/sysroots/x86_64-pokysdk-linux/usr/bin/python2

link:/root/.arduino1...


Accepted Solutions
Highlighted
Employee
18 Views

Hi lewatoto,

I'm very sorry for the delay in my reply. I wanted to let you know that this issue has been fixed in the Arduino IDE 1.6.7.

Peter.

View solution in original post

2 Replies
Highlighted
Employee
18 Views

Hello lewatoto,

This seems odd, I currently don't have Fedora installed, but let me some tests to see what I can find out.

Peter.

Highlighted
Employee
19 Views

Hi lewatoto,

I'm very sorry for the delay in my reply. I wanted to let you know that this issue has been fixed in the Arduino IDE 1.6.7.

Peter.

View solution in original post