Community
cancel
Showing results for 
Search instead for 
Did you mean: 
jbond1
Novice
895 Views

Board does not appear as drive and it does not flash

Hello,

We bought the Intel Edison Arduino breakout board. First, we flashed the Yocto image on the board and everything seemed to work fine, until we tried to use opencv. we realized that some of the kernel modules fail to install even when we try to reboot the board. in addition, we noticed that the board does not appear as a drive anymore. we were trying to re-flash the image on the board but we couldn't as the drive does not show up (we are using a Mac).

when we tried to install modules needed for opencv, this is what we got:

.amazonaws.com/opencv/v3.0.0/Release/node-v14-linux-ia32.tar.gz' (1)

npm ERR! Linux 3.10.17-poky-edison+

npm ERR! argv "node" "/usr/bin/npm" "install"

npm ERR! node v0.12.7

npm ERR! npm v2.11.3

npm ERR! code ELIFECYCLE

npm ERR! opencv@3.0.0 install: `node-pre-gyp install --fallback-to-build`

npm ERR! Exit status 1

npm ERR!

npm ERR! Failed at the opencv@3.0.0 install script 'node-pre-gyp install --fallback-to-build'.

npm ERR! This is most likely a problem with the opencv package,

npm ERR! not with npm itself.

npm ERR! Tell the author that this fails on your system:

npm ERR! node-pre-gyp install --fallback-to-build

npm ERR! You can get their info via:

npm ERR! npm owner ls opencv

we tried to reboot the board the error we got was:

Failed to start Load Kernel Modules. (during rebooting process)

 

We found this solution on the internet and we tried to follow it but the end result we the following:

here's the link for the solution we found ->

the result we got -->

terminal 1 (edison)

U-Boot 2014.04 (Jun 19 2015 - 12:05:55)

Watchdog enabled

DRAM: 980.6 MiB

MMC: tangier_sdhci: 0

In: serial

Out: serial

Err: serial

Hit any key to stop autoboot: 0

boot >

boot >

boot > c

boot > run do_flash

Saving Environment to MMC...

Writing to MMC(0)... done

GADGET DRIVER: usb_dnl_dfu

terminal window 2 (host machine)

xxx@12.366.434.45. ~: ./flashall.sh

./flashall.sh: line 8: brew: command not found

./flashall.sh: line 16: greadlink: command not found

usage: dirname path

./flashall.sh: line 127: -o: command not found

Usage: flashall.sh [-h][--help][--recovery]

Update all software and restore board to its initial state.

<p style="font-size: ...
2 Replies
Pedro_M_Intel
Employee
56 Views

Hello teambond1,

I see, you were trying the flashall method, right? Since it did not help you, did you try to use the Flash Tool Lite Recovery method?

Flash Tool Lite is available for OSX and it can be found in https://software.intel.com/en-us/iot/hardware/edison/downloads Intel® Edison Downloads alongside a guide on how to use it. Try it and let us know.

Peter.

Carlos_M_Intel
Employee
56 Views

Hi teambond1,

Have you been able to work with your board again? Did you try with the https://software.intel.com/en-us/articles/flash-tool-lite-user-manual Flash Tool Lite?

Are you running the /docs/DOC-25154 flashall.sh script on the Mac's terminal? I'm not sure if you are in the folder where you have the files for the image.

Also, which image version are you using to flash the board?

Regards,

Charlie

Reply