Community
cancel
Showing results for 
Search instead for 
Did you mean: 
VBuso
Beginner
1,102 Views

Building 20160606: Problem Fetching icedtea-2.1.3.tar.gz

I have successfully built the 20160606 image several times before (using already two patches from here: https://github.com/Squonk42/edison-yocto-docker/tree/master/edison-source edison-yocto-docker/edison-source at master · Squonk42/edison-yocto-docker · GitHub for libraries having the wrong MD5 or now inexistent) but now it seems it is impossible to fetch icedtea-2.1.3.tar.gz from http://gnu.wildebeest.org/download/source/icedtea-2.1.3.tar.gz http://gnu.wildebeest.org/download/source/icedtea-2.1.3.tar.gz

The error at compilation time is the following:

WARNING: Failed to fetch URL http://icedtea.wildebeest.org/download/source/icedtea-2.1.3.tar.gz%3Bname%3Diced http://icedtea.wildebeest.org/download/source/icedtea-2.1.3.tar.gz;name=iced, attempting MIRRORS if available

ERROR: Fetcher failure: Fetch command failed with exit code 8, output:

http://gnu.wildebeest.org/download/source/icedtea-2.1.3.tar.gz: http://gnu.wildebeest.org/download/source/icedtea-2.1.3.tar.gz:

2017-01-07 21:50:15 ERROR 404: Not Found.

ERROR: Function failed: Fetcher failure for URL: 'http://icedtea.wildebeest.org/download/source/icedtea-2.1.3.tar.gz%3Bname%3Diced http://icedtea.wildebeest.org/download/source/icedtea-2.1.3.tar.gz;name=iced'. Unable to fetch URL from any source.

ERROR: Logfile of failure stored in: /home/edison/Workspace/iot-devkit-yp-poky-edison-20160606/build_edison/tmp/work/x86_64-linux/icedtea7-native/2.1.3-r1.0/temp/log.do_fetch.8534

ERROR: Task 2976 (/home/edison/Workspace/iot-devkit-yp-poky-edison-20160606/build_edison/../poky/meta-java/recipes-core/icedtea/icedtea7-native_2.1.3.bb, do_fetch) failed with exit code '1'

NOTE: Tasks Summary: Attempted 2070 tasks of which 366 didn't need to be rerun and 1 failed.

Waiting for 0 running tasks to finish:

Summary: 1 task failed:

/home/edison/Workspace/iot-devkit-yp-poky-edison-20160606/build_edison/../poky/meta-java/recipes-core/icedtea/icedtea7-native_2.1.3.bb, do_fetch

Summary: There were 5 WARNING messages shown.

Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

Has anyone found a solution to compile anyway and bypass this or maybe not include java altogether?

Intel... really, do something at one point. I love your product but this is soooooo frustrating to develop on it when obviously it looks like no-one is in charge of maintaining the software. We already needed two patches made by the community to compile the image and now this ?

How can you still write this on your site:

"Run the following commands to build the Intel® Edison board image:

source oe-init-build-env ../build_edison/

bitbake edison-image u-boot"

It's been month it doesn't work anymore. Where are you guys ?

0 Kudos
8 Replies
LGoet
Novice
105 Views

Hi c

I had a similar error. To fix it I did this: . You have to comment these two lines in /poky/meta-intel-edison-distro/recipes-core/images/edison-image.bb:

  • IMAGE_INSTALL += "iotkit-comm-js"
  • IMAGE_INSTALL += "iotkit-comm-c-dev"

Then you have to replace your meta-java layer with the files downloaded from here: http://git.yoctoproject.org/cgit.cgi/meta-java/commit/recipes-core/icedtea http://git.yoctoproject.org/cgit.cgi/meta-java/commit/recipes-core/icedtea.

If you did this you will get the next error: "ParseError at /home/ubuntu/iot-devkit-yp-poky-edison-20160606/build_edison/../poky/meta-java/recipes-extended/rxtx/rxtx_2.2.0.bb:31: Could not inherit file classes/remove-libtool.bbclass"

You can fix this error like this: http://www.variscite.com/support-forum/viewtopic.php?t=277 openjdk7 failures... - Variscite Forums

Now I got the error that edison-image requires openjdk8. Some people say it would help to have openjdk installed ( ) but it didnt work so far. (I installed openkdk8 like this on Ubuntu 14.04: http://askubuntu.com/questions/464755/how-to-install-openjdk-8-on-14-04-lts java - How to install OpenJDK 8 on 14.04 LTS? - Ask Ubuntu )

So I fixed some errors but I dont know how to fix the openjdk8 error. Anyone an Idea?

You can try to build an image with an older version: (Answere 2) or with an edison-src file (latest 25.05.2015). Thats not the best way but it seems to work and until may 2016 the latest edison-src file was up to date I think.

~Leon

VBuso
Beginner
105 Views

Hi Leon

Thanks for the quick reply, I'll try your advice and tell you how it went.

I would like to works with the latest build and not a previous version, in order to help other move forward based on the last version always.

For now I have managed to finish the compilation by linking to a version of icedtea-2.1.3.tar.gz put on a my dropbox account (that I already fetched in a previous build).

To be more thourough, I have commented the line 10 of the file "/home/edison/Workspace/iot-devkit-yp-poky-edison-20160606/poky/meta-java/recipes-core/icedtea/openjdk-7-release-03b147.inc" and added another one instead like this:

# ICEDTEA_URI = "http://icedtea.wildebeest.org/download/source/%24 http://icedtea.wildebeest.org/download/source/${ICEDTEA}.tar.gz;name=iced"

ICEDTEA_URI = "https://www.dropbox.com/s/1jiqkn1bxiown03/icedtea-2.1.3.tar.gz%3Fdl%3D1%3Bname%3Diced https://www.dropbox.com/s/1jiqkn1bxiown03/icedtea-2.1.3.tar.gz?dl=1;name=iced"

Then I tried to compile and the fetch worked but I had an error at the very next step when yocto tries to patch the file:

ERROR: Command Error: exit status: 1 Output:

Applying patch disable-library-checks.patch

can't find file to patch at input line 5

Perhaps you used the wrong -p or --strip option?

The text leading up to this was:

--------------------------

|Index: icedtea-2.1.3/configure.ac

|===================================================================

|--- icedtea-2.1.3.orig/configure.ac 2012-10-17 10:18:59.262849964 +0200

|+++ icedtea-2.1.3/configure.ac 2012-11-23 09:39:02.244405345 +0100

--------------------------

No file to patch. Skipping patch.

4 out of 4 hunks ignored

Patch disable-library-checks.patch does not apply (enforce with -f)

ERROR: Function failed: patch_do_patch

ERROR: Logfile of failure stored in: /home/edison/Workspace/iot-devkit-yp-poky-edison-20160606/build_edison/tmp/work/x86_64-linux/icedtea7-native/2.1.3-r1.0/temp/log.do_patch.958

ERROR: Task 2973 (/home/edison/Workspace/iot-devkit-yp-poky-edison-20160606/build_edison/../poky/meta-java/recipes-core/icedtea/icedtea7-native_2.1.3.bb, do_patch) failed with exit code '1'

NOTE: Tasks Summary: Attempted 2125 tasks of which 2090 didn't need to be rerun and 1 failed.

Waiting for 0 running tasks to finish:

Summary: 1 task failed:

/home/edison/Workspace/iot-devkit-yp-poky-edison-20160606/build_edison/../poky/meta-java/recipes-core/icedtea/icedtea7-native_2.1.3.bb, do_patch

Summary: There was 1 WARNING message shown.

Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

Since the fetch was already done, I rechanged the lines 10-11 in /home/edison/Workspace/iot-devkit-yp-poky-edison-20160606/poky/meta-java/recipes-core/icedtea/openjdk-7-release-03b147.inc to set it as it was originally:

ICEDTEA_URI = "http://icedtea.wildebeest.org/download/source/%24 http://icedtea.wildebeest.org/download/source/${ICEDTEA}.tar.gz;name=iced"

# ICEDTEA_URI = "https://www.dropbox.com/s/1jiqkn1bxiown03/icedtea-2.1.3.tar.gz%3Fdl%3D1%3Bname%3Diced https://www.dropbox.com/s/1jiqkn1bxiown03/icedtea-2.1.3.tar.gz?dl=1;name=iced"

And then the rest of the compilation ran smoothly.

Needless to say, It is an ugly workaround, but it worked (for now).

LGoet
Novice
105 Views

Hi c,

Thats nice to hear - I will try your solution tomorrow. What system do you use (Ubuntu, Fedora etc.) and did you install something like openjdk8 because I always get this error? Hopefully this error wont appear with your solution.

~Leon

VBuso
Beginner
105 Views

Hi Leon,

I am on a virtual machine running Ubuntu 14.04 LTS.

I do not have openjdk8 installed, the only dependencies I downloaded are the ones listed in this file:

https://github.com/Squonk42/edison-yocto-docker/blob/master/ubuntu-build/Dockerfile edison-yocto-docker/Dockerfile at master · Squonk42/edison-yocto-docker · GitHub

Best of luck to you.

LGoet
Novice
105 Views

Hi c,

It works perfectly with the patch you mentioned in your first post and with the dependencies.

Do you have any idea how to install selinux, apparmor or smack.

Thanks for your help - that was great

~Leon

idata
Community Manager
105 Views

Hello all,

I see I am not alone trying to build edison last image without sucess. I amd really lost in the cold.

Cant understand why intel does not provide a frozen zip with all needed inside.

Could some of you please upload the whole folder zipped to a dropbox or similar? I feel unable to make it work.

Thanks!

LGoet
Novice
105 Views

Hi wjax,

You can get the full folder with all generated files from here https://github.com/Squonk42/edison-yocto-docker GitHub - Squonk42/edison-yocto-docker: Building an Intel Edison Yocto Linux image using docker. via docker (see "Usage").

For me it worked like descripted above with all the patches c mentioned in his first post and with the dependencies installed (listed here https://github.com/Squonk42/edison-yocto-docker/blob/master/ubuntu-build/Dockerfile edison-yocto-docker/Dockerfile at master · Squonk42/edison-yocto-docker · GitHub).

So I only used that files for building: https://github.com/Squonk42/edison-yocto-docker/tree/master/edison-source edison-yocto-docker/edison-source at master · Squonk42/edison-yocto-docker · GitHub

Hope it will work for you, too.

~Leon

FIvan
New Contributor I
105 Views

From this commit: http://git.yoctoproject.org/cgit/cgit.cgi/meta-java/commit/?h=master-next&id=8b028a5e67c8081a4ecd65d... meta-java - Layer containing recipes for OpenJDK and other open source Java-related components

Change the file poky/meta-java/recipes-core/icedtea/openjdk-7-03b147/fix-checksums.patch

--- icedtea-2.1.3/Makefile.am 2016-10-18 15:31:45.451073805 +0200

+++ icedtea-2.1.3/Makefile.am 2016-10-18 15:42:14.651066400 +0200

@@ -12,13 +12,13 @@

LANGTOOLS_CHANGESET = fd2fdb20d858

OPENJDK_CHANGESET = f89009ada191

-CORBA_SHA256SUM = f61dad8d484e4a9e645b7fb73da87bc44f9986a074629154f37ed46be05f5b84

-HOTSPOT_SHA256SUM = 09a64fca0beff0759ef1b461d63ed6a00e43032972781bb3a55e49d8b93f67d0

-JAXP_SHA256SUM = 9cfbc0efaface20f7188870b9bf5b0ebc73d745cd9a49d013cd4e81ba223ccdc

-JAXWS_SHA256SUM = 6d0858d46b68d6e8488e70d1675e5b656aeb4ef51e8ee4e330e77219f92c1c0c

-JDK_SHA256SUM = 11146763409098a42dd9896f3fb7e7324a58c5cff5298009eb347ad26abeed51

-LANGTOOLS_SHA256SUM = 3a4039348aa49547fffa96563b77b704c72e2ac3ead2c132843ba1e9fe4dbad2

-OPENJDK_SHA256SUM = 0f2e414fee619e78c33bceaee7c440efa598d651b23a75fd61e1282ad6001839

+CORBA_SHA256SUM = 00bf0b0996484db3d0497345ca5b14db4ffb2288b6c7adf8a003b2eafc396fb2

+HOTSPOT_SHA256SUM = 69719a9657b15e6bef1bef137a15d830293091fbc46616fe8759e863ba904442

+JAXP_SHA256SUM = bb4beb62fae52d0ff871aefd64ae54eaed8978bff87df1e23f1bfead40ceae6d

+JAXWS_SHA256SUM = 566778320a0fa18ca93427d6afadc8bd3e416fd8249f9ce88e37e215f9295335

+JDK_SHA256SUM = b24bf93559804610a6e1078bea94adcec1b2f818dd600b12304926f6e86c6747

+LANGTOOLS_SHA256SUM = 10fee41a0cdd1b166ff78e6426430c76af0f2358d026c181d325af1e41646c34

+OPENJDK_SHA256SUM = 5efd8e66f18fcbf45527bcc74aa3e6ed11f66bc793c88e3841925c4acb4827ba

CACAO_VERSION = a567bcb7f589

CACAO_SHA256SUM = d49f79debc131a5694cae6ab3ba2864e7f3249ee8d9dc09aae8afdd4dc6b09f9

And the file poky/meta-java/recipes-core/icedtea/icedtea7-native_2.1.3.bb

require openjdk-7-release-03b147.inc

PR = "${INC_PR}.0"

ICEDTEA = "icedtea-2.1.3"

SRC_URI[iced.md5sum] = "200e74ad440f9c4bfa21cc2bd94b4325"

SRC_URI[iced.sha256sum] = "1929e57eb6718d30735e1e04e9e129457f845f7d7a8404b2b028740d0779ddb6"

HOTSPOT_CHANGESET = "a456d0771ba0"

SRC_URI[hotspot.md5sum] = "625d903e79e4f9aaf21cf98e369118e1"

SRC_URI[hotspot.sha256sum] = "69719a9657b15e6bef1bef137a15d830293091fbc46616fe8759e863ba904442"

CORBA_CHANGESET = "79ee8535bc51"

SRC_URI[corba.md5sum] = "f9aae602c4d31203fcbf8dcfc5560ad9"

SRC_URI[corba.sha256sum] = "00bf0b0996484db3d0497345ca5b14db4ffb2288b6c7adf8a003b2eafc396fb2"

JAXP_CHANGESET = "77e7219c7424"

SRC_URI[jaxp.md5sum] = "440258a557c3cf0d585304a04ab060b8"

SRC_URI[jaxp.sha256sum] = "bb4beb62fae52d0ff871aefd64ae54eaed8978bff87df1e23f1bfead40ceae6d"

JAXWS_CHANGESET = "d92eda447bca"

SRC_URI[jaxws.md5sum] = "52b1d409628184988ff0f1d1e4d0a853"

SRC_URI[jaxws.sha256sum] = "566778320a0fa18ca93427d6afadc8bd3e416fd8249f9ce88e37e215f9295335"

JDK_CHANGESET = "d7ecb57d3c61"

SRC_URI[jdk.md5sum] = "db2a0f91f27ad7ebbc68db53691ca403"

SRC_URI[jdk.sha256sum] = "b24bf93559804610a6e1078bea94adcec1b2f818dd600b12304926f6e86c6747"

LANGTOOLS_CHANGESET = "fd2fdb20d858"

SRC_URI[langtools.md5sum] = "702becdfee546841ed038c79fa1a9909"

SRC_URI[langtools.sha256sum] = "10fee41a0cdd1b166ff78e6426430c76af0f2358d026c181d325af1e41646c34"

OPENJDK_CHANGESET = "f89009ada191"

SRC_URI[openjdk.md5sum] = "2bc941373ca4b033c9a25f972eec7858"

SRC_URI[openjdk.sha256sum] = "5efd8e66f18fcbf45527bcc74aa3e6ed11f66bc793c88e3841925c4acb4827ba"

Reply