Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MMigl
Novice
1,023 Views

Building 64-bit yocto image

I'm trying to build a 64-bit Intel Edison kernel & rootfs.

I've downloaded Edison sources, and I was able to bitbake and flash the standard image, so Yocto setup looks fine.

Now I've enabled 64-bit kernel by running

bitbake virtual/kernel -c menuconfig

then I did overwrite the defconfig file as stated in the Intel Edison Board Support Package user guide, but now bitbake fails throwing these errors:

/test/edison/yocto/edison-src/out/linux64/build/tmp/work/edison-poky-linux/linux-yocto/3.10.17-r0/linux/scripts/mod/empty.c:1:0: error: code model 'kernel' not supported in the 32 bit mode

/test/edison/yocto/edison-src/out/linux64/build/tmp/work/edison-poky-linux/linux-yocto/3.10.17-r0/linux/scripts/mod/empty.c:1:0: sorry, unimplemented: 64-bit mode not compiled in

Any advice on how to solve this?

6 Replies
Matthias_H_Intel
Employee
100 Views

are you sure Edison supports 64-bit?

if yes, not sure whether the BSP can just be transferred to 64-bit.

On your issue:

- did you compile from scratch? Maybe there is still some cached data otherwise?

- which host OS do you have? if it's 32-bit you might need some tweaks for in order to make gcc happy.

MMigl
Novice
100 Views

mhahn looking into /proc/cpuinfo you can see the LM flag which confirms it is a 64-bit processor.

I'm compiling from scratch, I did try to "make clean" but still get the same result.

The OS is 64-bit ubuntu (also tried in a clean debian vagrant box), gcc has been downloaded by yocto so I *hope* it is a tested version

Carlos_M_Intel
Employee
100 Views

Hi tinito,

What is the purpose of enabling the 64 bit kernel in your image?

What other changes have you done in the image?

Regards,

Charlie

MMigl
Novice
100 Views

CMata_Intel I need to support docker, and I would prefer to enable 64-bit support so all standard docker images should work, while compiling 32-bit docker binaries (which I did) requires 32-bit docker containers off course.

I added LXC support and a few additional IPTABLES chains in the kernel configration, nothing else.

Matthias_H_Intel
Employee
100 Views

often helpful on issues with bitbake is to run the "devshell" task (i.e. in your case something like "bitbake -c devshell edison-linux"). This gives you a shell with all the environment set for the toolchain. There you may experiment directly in a shell (e.g. directly run make)

Carlos_M_Intel
Employee
100 Views

Hi tinito,

Do you have updates on this?

Are you cleaning the build folder at every attempt? Or are you starting from scratch?

Which gcc version do you have?

Did you try with "devshell"?

Which source files are you using? I would like to try it using your same changes.

Regards,

Charlie

Reply