Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DAlar2
Beginner
1,005 Views

CUPS install problems

What should i do?

Collected errors:

* satisfy_dependencies_for: Cannot satisfy the following dependencies for libavahi-common3:

* libc6 (>= 2.20) *

* opkg_install_cmd: Cannot install package libavahi-common3.

But i already had library:

Package libc6 (2.19-r0) installed in root is up to date.

1 Reply
Pablo_M_Intel
Employee
42 Views

Hi alarcondiegof,

Which image are you using? Are you using the AlexT repo to download the packages?

According to another thread, the prerequisites packages would be these ones:

opkg install http://repo.opkg.net/edison/repo/core2-32/ http://repo.opkg.net/edison/repo/core2-32/http://repo.opkg.net/edison/repo/core2-32/libavahi-common3... libavahi-common3_0.6.31-r11.1_core2-32.ipk

opkg install http://repo.opkg.net/edison/repo/core2-32/ http://repo.opkg.net/edison/repo/core2-32/http://repo.opkg.net/edison/repo/core2-32/libavahi-client3... libavahi-client3_0.6.31-r11.1_core2-32.ipk

opkg install http://repo.opkg.net/edison/repo/core2-32/ http://repo.opkg.net/edison/repo/core2-32/http://repo.opkg.net/edison/repo/core2-32/libcups2_1.7.5-r... libcups2_1.7.5-r0_core2-32.ipk

opkg install http://repo.opkg.net/edison/repo/core2-32/ http://repo.opkg.net/edison/repo/core2-32/http://repo.opkg.net/edison/repo/core2-32/libcupsimage2_1.... libcupsimage2_1.7.5-r0_core2-32.ipk

Now, once this is done you can proceed to install CUPS.

opkg install http://repo.opkg.net/edison/repo/core2-32/ http://repo.opkg.net/edison/repo/core2-32/http://repo.opkg.net/edison/repo/core2-32/cups_1.7.5-r0_co... cups_1.7.5-r0_core2-32.ipk

Did you already install the packages? You can check the whole thread following this link .

Regards,

PabloM_Intel

Reply