Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9872 Discussions

Can't Flash Edison - USB not recognized

New Contributor I

I have an early Edison with Arduino board. I came back to start using it again. I needed to update from Yacto 1.7 I believe it was.

I used the "new" installation system to update the firmware (windows 10 64 bit download).

I could see the Edison drive (I:)

I downloaded the firmware, selected the zip file, the JASON file was found by the Phone Flash Tool.

I started the flash .. and at about 37% done the flash failed (unfortunately I did not write down the specifics)

Now I have a major problem.

1) I can no longer see the Edison drive (I:)

2) I get a USB error in windows (Unknown USB device (device Descriptor failed)

If I try to run The phone flash tool, it asks that I connect the Edison board. No matter what I do, it does not see the board.

I can get into the console which shows U-Boot 2014.4 (July 19, 2015) after I hit the key.

This hangs at "GADGET DRIVER: usb_dn1_dfu"

I am starting to think the USB hardware has failed ...

I have search for a solution everywhere I can think of to no avail ... Please help


I have also tried the thread here

I get a message "Device has DFU interface, but has no DFU functional descriptor" the fix the author of the above post does not work in my case.

It is as if the USB hardware records / info has been wiped on the Edison itself.

Message was edited by: Richard Ellis - Updated to reflect yet another attempt at repairing this.

4 Replies
New Contributor I

Ok, next update.

I also reviewed the post here and tried it

I have installed / reinstalled the device drivers and still get the "Device had DFU interface, but has no DFU functional descriptor"

In Windows 10, Device manager under USB controllers

the board shows up as "Unknown USB device (Device Descriptor Request Failed"

I have tried multiple cables - no change

Remove device, then search for new devices - no change

Different computers - no change

With just usb cables AND with usb cables and a 12v 1.6A Power supply - no change or difference.

I have tried unplugging cables and using ctrl-C to get to boot> - no difference

I need a way to re-flash without the dependency on usb and wireless won't work since the Edison cannot get into Linux

This was working before I tried the update, so it must be a firmware thing - I just can't figure it out


Hello Irakandjii,

There are two ways to flash the Edison module:

  • Using the flashall script: This method is described in the following document:

For the flashall method you have to install dfu-util. Did you install it?

Additionally, make sure you have the Edison's driver installed. An integrated installer is available here:, but you might want to try the standalone driver which is available here: I recommend you to install the standalone driver, and then try again with the Flash Tool Lite.

If there is not change at all, then I recommend you to submit a warranty ticket using the following form so the Warranty Team can provide you further assistance: Intel Support



New Contributor I


1) Yes dfu-util was installed properly.

2) The integrated installer was installed and was the start of the problem. It created more problems because it would not recognise the Edison as was too inflexible to deal with the exception. So the DFU / flashall.bat approach was required.

I have recovered the board now. Here is what I found.

1) I had to pull my computer apart and install some dedicated USB 2.0 ports (off an internal header) thank goodness I had the parts.

a) Once I did this I noticed that a Intel DFU device showed up. BUT! if I used the console to start a download boot> or ctrl-C "the USB error reappeared".

b) So I powered down and reinserted the Edison into USB 2.0, getting the DFU device back in device manager.

2) Once the DFU device was stable, I ran flashall.bat from the command prompt on my desktop.

a) this worked

3) I can now see the Edison drive and the image is now installed.

Key Learning: Make sure you can see the Intel DFU device in Device manager before you run flashall.bat

As to why Intel would require USB 2.0 for this to work is anyone's' guess. My laptop had zero (0) USB 2.0 Ports, My Surface has no USB 2.0 ports. The USB 3.0 on my desktop are Intel's own X99 based units... go figure!


Thanks a ton Irakandjii,

I had won a really nice kit at the Intel IOT Roadshow in Bangalore, Being a mechanical engineer turned photographer, IOTs roadshow was calling the engineer in me to be a part of it. Guess what I made it to this roadshow from amongst 1200 applicants and without knowing a line of code and just some very basic C programming skills.

The board could just not be initialized for around a week and finally your post helped me resolve this issue. You were right. On my Dell XPS the two USB 3.0 Ports just dont help with the device getting recognized. I tried your method and this just worked fabulously well!!

Thanks again. Now getting back to seeing how arduino works and what I can do with it.