Community
cancel
Showing results for 
Search instead for 
Did you mean: 
KKyle
Novice
1,029 Views

Cannot connect to edison's wifi server over belkin router.

I created a program that used Edison's WiFi server which worked fine at my house. I recently moved back to college and the WiFi server would no longer load when I typed in the IP address. I am using the break out board with arduino so i tried using the SimpleWebSererWifi example and that did not work either. It is connecting the internet and printing a new IP address to go to but it will not load when typed into google.

When I was at home I needed to change the WiFiServer server(80) to server(81) for it to work properly and then type in the IP like this 198.162.2.11:81 for it to work. This does not work at my new house and leaving it at 80 does not work either. I went back home for a day and brought my Edison with me to see if it still worked there and it did ruling out any problems with the board or the program. The only thing I can think of is it must have to do with the router I'm using which is a Belkin, that is the only thing that is different.

If anyone has any suggestions on how I can modify my router or my code to make it work properly I would greatly appreciate it.

Tags (2)
0 Kudos
2 Replies
idata
Community Manager
45 Views

Hi Kyle,

 

 

Did you make sure not to be working behind a proxy? That might be causing the issue. I would also like to know if these other routers (the ones that are not working with your Edison) are assigning addresses to more than one device. Also, what type of connection are you using at home and in college?

 

 

Regards,

 

-Pablo
idata
Community Manager
45 Views

Hi Kyle,

 

 

Do you have updates on this case?

 

 

Regards,

 

-Pablo
Reply