Community
cancel
Showing results for 
Search instead for 
Did you mean: 
glian4
Novice
1,761 Views

Collected errors: * parse_from_stream_nomalloc: Missing new line character at end of file!

Jump to solution

when I use the command "opkg update "

it gives me this message.

I found someone use edison in this communities have the same problem ,and not solved ,I am afrad of the same thing happen to me.

the message like this:

//=============================================

root@edison:~# opkg update

Downloading http://iotdk.intel.com/repos/2.0/intelgalactic/Packages http://iotdk.intel.com/repos/2.0/intelgalactic/Packages.

Updated list of available packages in /var/lib/opkg/iotkit.

Collected errors:

* parse_from_stream_nomalloc: Missing new line character at end of file!

root@edison:~#

//===============================================

and this happens in both edison-image-ww25.5-15 and edison-iotdk-image-280915

just after I flashed new firmware to edison and setup wifi.

I try to delete the files in /ete/opkg or just add a new line by enter an ENTER.

then the first time to input " opkg update" ,it is ok ,but second time it will give me the same error message.


Accepted Solutions
glian4
Novice
448 Views

well ,finally, I found if I use another access to internet ,it works well, so the problem comes from internet access.......

Thank you all for your help~~

View solution in original post

6 Replies
glian4
Novice
448 Views

in this error , the user have similar problem

Sergio_A_Intel
Employee
448 Views

Hi,

Did you do any additional changes after flashing? In my case, I flashed to the latest image "edison-iotdk-image-280915". Then configured wifi with configure_edison –setup. Then put

src/gz all http://repo.opkg.net/edison/repo/all http://repo.opkg.net/edison/repo/all

src/gz edison http://repo.opkg.net/edison/repo/edison http://repo.opkg.net/edison/repo/edison

src/gz core2-32 http://repo.opkg.net/edison/repo/core2-32 http://repo.opkg.net/edison/repo/core2-32

in /etc/opkg/base-feeds.conf and ran opkg update.

I didn't receive any errors, are these the exact same steps you followed? Try to delete everything in /etc/opkg/base-feeds.conf and put the lines I mentioned above in base-feeds.conf.

Sergio

glian4
Novice
448 Views

thank you for reply ,I followed your instruction and got the following message.

I think this strange problem may cause by some low level file or internet operation errors?

I don't know ,

glian4
Novice
448 Views

I flashed it again, and after setting up the wifi ,I just type opkg update twice ,and got following message.

glian4
Novice
448 Views

some one mentioned the disk space ,this is my partition

glian4
Novice
449 Views

well ,finally, I found if I use another access to internet ,it works well, so the problem comes from internet access.......

Thank you all for your help~~

View solution in original post