Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SAsho1
New Contributor I
2,098 Views

Color OLED SSD1351 driver testing

Driver for 1.5" color OLED using SSD1351 is available now.

https://github.com/intel-iot-devkit/upm/tree/master/src/ssd1351 upm/src/ssd1351 at master · intel-iot-devkit/upm · GitHub

Its not working for me with the Densitron module I have.

Anyone here can test it for me if you have a Color OLED which uses SSD1351

Not sure if it works with the Freetronics module or not.

My older thread on this topic is here

TIA

5 Replies
Carlos_M_Intel
Employee
51 Views

Hi Sukesh,

I would like to know more information about the problem you have.

1. Which image are you using?

2. Which expansion board are you using?

3. What is the error message you are having?

4. Which UPM & MRAA libraries versions you have?

5. Which example are you using to test this?

I checked your other thread, have you been able to test the SPI signals to identify the problem (frequency, magnitude, noise, wrong data..)?

Please let us know how you are testing this.

Regards,

Charlie

Carlos_M_Intel
Employee
51 Views

Hi Sukesh,

Do you have updates on this? If you still have problems with your module and board please let us know the answer of the questions above.

Regards,

Charlie

SAsho1
New Contributor I
51 Views

Thank you for the follow up Charlie.

I am working with an Intel resource offline on this but to answer your questions

1. Which image are you using?

 

The latest available publically over here for download

2. Which expansion board are you using?

 

The board is a custom designed board which has more components as well.

3. What is the error message you are having?

I was getting kernel panic as well as nothing shown up on the display

4. Which UPM & MRAA libraries versions you have?

 

Latest public version available.

 

5. Which example are you using to test this?

 

Using the same sample provided with the driver.
Carlos_M_Intel
Employee
51 Views

Hi Sukesh

Do you want to continue using this thread or can we marked as resolved?

Please let me know if you are going to work with the offline resource instead of using this thread.

Regards,

Charlie

SAsho1
New Contributor I
51 Views

Thank you Charlie to response.

Yes we can close this thread.

We got the display working by changing the SPI mode setting in the driver to SPI_MODE0 instead of SPI_MODE3.

m_spi.mode(mraa::SPI_MODE0);

Hope that helps this thread.