Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
1,251 Views

Compiling PD on Edison Issues

I feel like I am really close to getting a .pd patch to work, but I'm not sure what is going wrong.

Here is where I am at:

 

- set sound card as default in ALSA and can successfully play sample sound files in /usr/share/sounds/alsa/ using "aplay"

- have downloaded Pure Data to root folder

- created sine.pd patch file, taken from the tutorial I link to below in the root dir

I'm fairly new to command line, so I've been looking around for PD and Edison tutorials and found http://charlesmartin.com.au/blog/2015/2/5/running-pd-on-the-intel-galileo this for the Galileo.

In the tutorial, under "Getting Packages", I have hooked up to Alex T's repo (thanks Alex!), however I was not able to install uclibc. Everything else I was able to install fine in the root dir.

Then, following the INSTALL.txt file in Pure Data, I used these commands:

./autogen.sh

./configure

With each return it goes into the directories and runs through, everything looks ok, but I'm not sure if I am missing a critical error buried somewhere.

When I run the last recommended command:

make

 

I get this at the bottom of the run:

Makefile:914: recipe for target 'all-recursive' failed

make[1] *** [all-recursive] Error 1

make[1]: Leaving directory '/pure-data'

Makefile:813: recipe for target 'all' failed

make: *** [all] Error 2

I go to my root dir. and run the sine.pd patch:

pd -nogui -blocksize 1024 sine.pd

It opens (I assume) and prints:

print: turned dsp on.

The problem is that I do not hear anything when I plug headphones into the sound card, and have played samples and used timbre.js successfully before.

What I think it may be is that I am not installing Pure Data correctly. What does the Edison use to install applications?

Honestly I do not know how to tell if it is installing correctly while it is running through files, except for pulling out those two errors after the "make" command.

Any suggestions as to why this might not be working are appreciated. Thank you!

5 Replies
Highlighted
New Contributor I
10 Views

Can you give more lines of the `make` error?

Haven't got pd to work myself yet either. If I recall correctly, it did compile and run sketches but didn't play audio.

0 Kudos
Highlighted
Employee
10 Views

Hi postITnote ,

You can't use the command:

echo "src/gz all http://repo.opkg.net/galileo/repo/all http://repo.opkg.net/galileo/repo/all

src/gz clanton http://repo.opkg.net/galileo/repo/clanton http://repo.opkg.net/galileo/repo/clanton

src/gz i586 http://repo.opkg.net/galileo/repo/i586 http://repo.opkg.net/galileo/repo/i586" >> /etc/opkg/base-feeds.conf

This is because the repo: http://repo.opkg.net/galileo/repo http://repo.opkg.net/galileo/repo is for Galileo/uclibC image and not for Edison. For Edison, you must follow the instructions in: http://alextgalileo.altervista.org/edison-package-repo-configuration-instructions.html Edison Package Repo Configuration Instructions

You can try with:

root@edison:~# echo "src/gz all http://repo.opkg.net/edison/repo/all http://repo.opkg.net/edison/repo/all

 

src/gz edison http://repo.opkg.net/edison/repo/edison http://repo.opkg.net/edison/repo/edison

 

src/gz core2-32 http://repo.opkg.net/edison/repo/core2-32 http://repo.opkg.net/edison/repo/core2-32" >> /etc/opkg/base-feeds.conf

root@edison:~# opkg update

root@edison:~# opkg install git

root@edison:~# git clone git://git.code.sf.net/p/pure-data/pure-data

root@edison:~# cd pure-data

root@edison:~/pure-data# ./autogen.sh

root@edison:~/pure-data# ./configure --enable-alsa

root@edison:~/pure-data# make

root@edison:~/pure-data# make install

Let us know the result of trying with this

Regards,

Charlie

Highlighted
New Contributor I
10 Views

Thanks CMata_Intel,

I pointed to that tutorial, but I didn't use the Galileo repo for the reason you state. I am using AlexT_Intelrepo. I've been piecing together any info I can find and excluding the parts that I believe won't work. After writing to my base-feeds.config file to pull from Alex_T's repo, I went through the commands you suggest before I wrote the post, which lead to the noted errors and with a patch that opened, but I couldn't hear. I'm going to get some advice today from a friend and will update if it moves forward.

 

s89

Interesting. Perhaps my audio isn't set up correctly for PD either. In my configuration summary it seems to say that the jack is not enabled, which I tried to correct with.

./configure --enable-jack

However, it still says "no".

 

Here are the links to my gists with everything that spits out after each command.

https://gist.github.com/laraCat/1d2b3dec16ae3fab6b47 ./autogen.sh

https://gist.github.com/laraCat/6c3db7ce16de1a98259d ./configure --enable-alsa

https://gist.github.com/laraCat/b6dbd57ac8d9c363cce2 make

https://gist.github.com/laraCat/f43ff20dab29bae7d43b make install

 

Thanks for looking!

 

 

 

 

 

 

 

 

 

 

0 Kudos
Highlighted
Employee
10 Views

Hi postITnote,

Do you have updates on this?

Regards,

Charlie

0 Kudos
Highlighted
New Contributor I
10 Views

No, I've needed to move on using Timbre.js for now. Which I am having issues with as well. Eventually I will get back to it.

Thanks

0 Kudos