Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9881 Discussions

Debug debug messag on ttyS1

idata
Community Manager
1,915 Views

Hello;

i use the meta-clanton_v1.1.0-dirty.tar.gz and create the images.

images run successfully .

We need two uart for our iot applications.so we want to stop the debug console on ttyS1.

So please help us to solve this problem,

Thanks & best Regards;

Nikunj Patel

4 Replies
idata
Community Manager
115 Views

Hi Nikunj,

 

 

If you want to use two UARTs at the same time in the Galileo you'd have to redirect the output of ttyS1 and use UART1, which can be found I the Arduino pins 2 and 3. Take a look at these links for some additional information on how to accomplish this:

 

http://www.gregorykelleher.com/blog/galileo_extra_serial http://www.gregorykelleher.com/blog/galileo_extra_serial

 

/thread/56827 https://communities.intel.com/thread/56827

 

https://github.com/intel-iot-devkit/mraa/issues/244 https://github.com/intel-iot-devkit/mraa/issues/244

 

 

-Sergio

 

idata
Community Manager
115 Views

Do you still need help with this thread? Were you able to use the two UARTs on the Galileo?

 

 

-Sergio

 

idata
Community Manager
115 Views

Thanks for your help

no more need for this thread

idata
Community Manager
115 Views

Thank you for letting us know this issue is resolved. If you have any doubts don't hesitate to open a new thread in the community.

 

 

-Sergio

 

Reply