Community
cancel
Showing results for 
Search instead for 
Did you mean: 
BBeno2
Novice
1,372 Views

Device cannot be added to IoT dashboard ("Device already exists")

Jump to solution

Hi,

This issue has been raised before, but I could not find a clear answer.

Basically, when I try to add my device to the Dashboard, I get the error:

Activation Rejected: {"code":1409,"message":" Device already exists"} --> error

I tried all the suggested solutions in the other posts (rebooted, cleared the registration data, re-activated, etc), but I always get the same result ("Device already exists"). I'm not doing anything special and I start from scratch, so why is this not working?

I'm using the latest image. This is the only device I have, so my Dashboard currently has 0 devices registered.

More specifically, here is what I did:

1. Dashboard>Devices>Trash icon (Delete all of them)

2. Reboot Edison: reboot

3. In this order:

systemctl status iotkit-agent

systemctl stop iotkit-agent

iotkit-admin initialize

Dashboard>MyAccount>Details>Refresh Activation Code

iotkit-admin activate "activation_code"

And that's where I get the error code.

I'm using my smartphone as a local hotspot for the Edison WIFI, and I use a separate network for the computer which accesses my Dashboard.

Thanks,

Benoit

0 Kudos
1 Solution
eiot
Beginner
90 Views

Hi.

I was in same trouble,but just now I could register my Edison.

my English is not good but hope you understand me

Is your Edison's device ID 00-00-00-00-31-00?

I tried to change my device ID by

iotkit-admin set-device-id < device ID you like >

And activate it.

I resolved it by this way.

View solution in original post

3 Replies
eiot
Beginner
91 Views

Hi.

I was in same trouble,but just now I could register my Edison.

my English is not good but hope you understand me

Is your Edison's device ID 00-00-00-00-31-00?

I tried to change my device ID by

iotkit-admin set-device-id < device ID you like >

And activate it.

I resolved it by this way.

View solution in original post

BBeno2
Novice
90 Views

Thanks edisondeiot. I don't have my kit with me today but I will try this tomorrow.

I don't remember if the ID was 00-00-00-00-31-00, but it was something similar.

Regards,

Benoit

BBeno2
Novice
90 Views

Excellent! It worked!

Thank you very much edisondeiot!

Incredible. Who would have known that we have to change the original unit ID.

I changed it to 00-00-00-00-48-00.

Reply