Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DGehl
Beginner
1,244 Views

Device information webpage doesn`t load.

Hello everyone,

 

I followed steps to set up Wi-Fi* network access from this link- https://software.intel.com/en-us/connecting-your-intel-edison-board-using-wifi https://software.intel.com/en-us/connecting-your-intel-edison-board-using-wifi

When i visit the page for device information, webpage doesn`t load until i use ifconfig usb0 down

as mentioned in above link.

But when i remove the usb and power the board, same problem exist.

Why this is happening?

 

Is there any permanent method to solve this problem instead of using usb0 down every time i power my board?

 

Thanks

 

0 Kudos
13 Replies
ASouz7
Honored Contributor II
116 Views

Hello dhiraj_gehlot,

You can get better answers in the Edison Community. I am transfering your thread to them for proper assistance.

Carlos_M_Intel
Employee
116 Views

Hi dhiraj_gehlot,

Which image are you using in your board? (You can run configure_edison –version for this)

If you are not using the 159 version I suggest you to update the image https://software.intel.com/en-us/iot/hardware/edison/downloads IoT - Intel® Edison Board Download | Intel® Developer Zone

Regards,

Charlie

Carlos_M_Intel
Employee
116 Views

Hi dhiraj_gehlot,

Have you been able to see the webpage with the device information?

Regards,

Charlie

DGehl
Beginner
116 Views

Hi CMata_Intel,

I am using 159 version.

Webpage with device information doesn`t load.

When i use ifconfig usb0 down its shows device information page and works fine.

Below is screenshot when i run "ifconfig".

 

 

 

Carlos_M_Intel
Employee
116 Views

Hi dhiraj_gehlot,

I suggest you to re-flash your image and then to configure the board with configure_edison –setup

Are you powering the board through the USB port or with a power supply? If you are powering the board with the USB port you could try to disable the USB RNDIS adapter.

Let me know if after doing this you get the same behavior.

Regards,

Charlie

Carlos_M_Intel
Employee
116 Views

Hi dhiraj_gehlot,

Do you have updates on this?

Did you try with the suggestions above?

Regards,

Charlie

DGehl
Beginner
116 Views

Hi CMata_Intel

I tried re-flashing image also re-install drivers. I am getting same behavior.

I tried disabling USB RNDIS adapter, still facing same problem.

I noticed few things:

After re-installing drivers below is the screenshot of device management:

After using ifconfig usb0_down and enabling USB RNDIS adapter it shows:

Can this cause any issue?

I again tried re-installing drivers and tried every thing still facing same problem.

Please help.

Carlos_M_Intel
Employee
116 Views

Hi,

Have you tried with different USB cables? Also are you completely sure that there are no problems with the USB ports of your PC?

Have you tried to power your board with a power supply?

After you configure your network connection with configure_edison –wifi, which is the output you get?

Are you trying to access to the webpage with the IP address of the board or with edison.local?

Please check your network configuration with cat /etc/wpa_supplicant/wpa_supplicant.conf? Is the information correct?

Check if you are getting the same output after configure_edison –showWiFiIP and ifconfig (with this one, check the information in wlan0)

Are you able to ping to google?

Regards,

Charlie

Carlos_M_Intel
Employee
116 Views

Hi,

Do you have updates on this?

Have you checked your network configuration?

Regards,

Charlie

DGehl
Beginner
116 Views

Hi CMata_Intel

I tried reflashing again.Below are the sceenshot of wlan0 output.

I am not able to ping google.

Tried accessing both from edison.local and the IP address, still facing same problem.

Now when i use ifconfig usb0_down wh

Carlos_M_Intel
Employee
116 Views

Hi,

Could you attach a screenshot of what you get after typing cat /lib/systemd/system/sshd.socket? You should have # BindToDevice=usb0 if this line is not commented, please add the # symbol at the beginning of the line.

If the only way to get this done is by running ifconfig usb0 down, an alternative could be to create a service to be running since boot that would run that command

Regards,

Charlie

DGehl
Beginner
116 Views

Hi CMata_Intel

Please find attached the screenshot after typing cat/lib/systemd/system/sshd.socket.

BindToDevice=usb0 was already commented. I think creating a service routine is only option.

Should i refer this link-

to create a service routine? 

Regards

Dhiraj

Carlos_M_Intel
Employee
116 Views

Hi Dhiraj,

Yes, I think that could work for you. Let us know if after setting this service you get better results.

Kind regards,

Charlie

Reply