Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
900 Views

Edi-Cam | Issue When Loading on Boot

Jump to solution

I currently am running https://github.com/drejkim/edi-cam Edi-Cam on the Intel Edison and am looking to run this on boot.

Edi-Cam works fine when I am not trying to load it on boot (webcam live feed appears in browser). However when loading on boot the video feed does not show but the web server is running and the page is up. I know that Edi-Cam is running on boot because I can restart the Edison and I am able to see the web server running, but no video feed. I used thishttp://www.tektyte.com/docs/docpages/edison-reference/runonstartup.html tutorial to help me run the server on boot.

Here is how I am currently running it on boot:

Running it as a service on boot:

yourscript.service executes the "yourscript.sh" file.

Using commands in the "yourscript.sh" file to load the server.js file:

For the most part it is working, but I think the order of file execution may be an issue?...

The service is running and the web server is up... no video feed is showing up.

Server running on boot, yet no video feed. What could the issue be?

Any help is much appreciated!


Accepted Solutions
Highlighted
Community Manager
11 Views

Hi bkhayes99,

I made some changes on both files (yourscript.sh and yourscript.service), and it worked.

Take a look at the file yourscript.services:

Most important you need to add the line Type=idle, if you don't this the Type remains on default. (Check this link: https://wiki.archlinux.org/index.php/systemd https://wiki.archlinux.org/index.php/systemd Section: Service Types).

I made those changes and the result was the same, so I edited the yourscript.sh file too:

I turned off and on the Edison and the codes worked, so I recommend you to try these changes.

I hope these codes works for you too.

Regards,

 

-Leonardo

View solution in original post

0 Kudos
2 Replies
Highlighted
Community Manager
12 Views

Hi bkhayes99,

I made some changes on both files (yourscript.sh and yourscript.service), and it worked.

Take a look at the file yourscript.services:

Most important you need to add the line Type=idle, if you don't this the Type remains on default. (Check this link: https://wiki.archlinux.org/index.php/systemd https://wiki.archlinux.org/index.php/systemd Section: Service Types).

I made those changes and the result was the same, so I edited the yourscript.sh file too:

I turned off and on the Edison and the codes worked, so I recommend you to try these changes.

I hope these codes works for you too.

Regards,

 

-Leonardo

View solution in original post

0 Kudos
Highlighted
Community Manager
11 Views

Hi bkhayes99,

 

 

Did you make the changes in your files? Did you successfully run Edi-Cam on boot?

 

 

Don't doubt to ask us if you still have issues with it.

 

 

Regards,

 

-Leonardo
0 Kudos