Intel® Makers
Intel® Edison, Intel® Joule™, Intel® Curie™, Intel® Galileo
Announcements
Welcome - This is a Peer-to-Peer Forum only. Intel has discontinued these products but you may find support from other customers on this Forum
9868 Discussions

Edision Ubilinux Access Point

RK10
Novice
3,361 Views

Hi guys,

I've downloaded and flashed the latest version of ubilinux (http://www.emutexlabs.com/files/ubilinux/ubilinux-edison-141030.tar.gz http://www.emutexlabs.com/files/ubilinux/ubilinux-edison-141030.tar.gz).

I connected the wifi to our company network and this worked without any problems. Then I tried to setup an access point on the edision. Therefore I changed the /etc/network/interfaces:

auto wlan0

iface wlan0 inet static

address 192.42.0.1

netmask 255.255.255.0

I rebooted the system and could not see any AP. Then I tried to start hostapd with

hostapd /etc/hostapd/hostapd.conf

which didn't work. I also tried to start hostapd with

service hostapd start

which didn't work either.

Is there anything else I've to consider?

Thanks so much for your help in advance,

duckhunter

0 Kudos
1 Solution
DHunt5
Valued Contributor I
316 Views

duckhunter,

To enable hostapd, you need to edit the /etc/default/hostapd file, and uncomment the DAEMON_CONF line, and add the location of your config file. Normally this would be:

DAEMON_CONF="/etc/hostapd/hostapd.conf"

You can edit your hostapd.conf to set the ESSID: "ssid=MyAP". Then, restart hostapd with

/etc/init.d/hostapd restart

Rgds,

Dave.

View solution in original post

10 Replies
RK10
Novice
316 Views

This is the kernel log, when I start hostapd:

[ 104.314953] CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : ff:ff:ff:ff:ff:ff scb_val.val 3

[ 104.489263] CFG80211-ERROR) check_dev_role_integrity : device role select failed

DHunt5
Valued Contributor I
317 Views

duckhunter,

To enable hostapd, you need to edit the /etc/default/hostapd file, and uncomment the DAEMON_CONF line, and add the location of your config file. Normally this would be:

DAEMON_CONF="/etc/hostapd/hostapd.conf"

You can edit your hostapd.conf to set the ESSID: "ssid=MyAP". Then, restart hostapd with

/etc/init.d/hostapd restart

Rgds,

Dave.

RGlov1
New Contributor I
316 Views

@David_J_Hunt I followed your reply post and I am receiving the Failed message:

[....] Starting advanced IEEE 802.11 management: hostapdrmdir[ctrl_interface]: No such file or directory

I am using the latest Ubilinux. I am not sure what to do to fix this issue and set my Wifi as an Access Point.

duckhunter what version of Ubilinux are you using?

xzhan35
New Contributor I
316 Views

dottedquad , I have the same faild mesage:

[....] Starting advanced IEEE 802.11 management: hostapdrmdir[ctrl_interface]: No such file or directory.

 

can you fix it ? how to fixed?

xzhan35
New Contributor I
316 Views

dottedquad I have fixed this fail.

you may update the hostapd file .you can build the hostapd file by yourself.

download hostapd-2.4.tar.gz

wget http://w1.fi/releases/hostapd-x.y.z.tar.gz

build:

tar xzvf hostapd-x.y.z.tar.gz cd hostapd-x.y.z/hostapd cp defconfig .config vi .config make

some erroe:

../src/drivers/driver_nl80211.c:25:31: fatal error: netlink/genl/genl.h: No such file or directory

 

compilation terminated.

 

make: *** [../src/drivers/driver_nl80211.o] Error 1

fixed:

sudo apt-get install libnl-dev libpopt-dev

then make success.

use the newest hostapd replace /usr/sbin/hostapd,

 

then run:

sudo /etc/init.d/hostapd restart

it works great.

RGlov1
New Contributor I
316 Views

Thank you for replying back with how to fix your issue. I still havent figured it out, but I will try what you mentioned and respond back in a couple of days.

xzhan35
New Contributor I
316 Views

dottedquad ok, if you have any question ,you can feedback to me .

RK10
Novice
316 Views

Thanks. It works great

GGerh
New Contributor I
316 Views

hey,

is it possible for you to post your hostapd.conf, something still not working on my edison...

thanks in advance

xzhan35
New Contributor I
316 Views

duckhunter, cat you post your hostapd.conf, because I always have the faild message :

[....] Starting advanced IEEE 802.11 management: hostapdrmdir[ctrl_interface]: No such file or directory.

 

I don't know how to fix it.

 

Reply