Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
2,292 Views

Edison Arduino WiFi Connecting Intermittently

Hi,

My Edison board connects to my wifi network intermittently. Sometimes when I boot up the board, the wifi connection seems automatic and I am able to hit the device page through the browser:

http://192.168.1.100/ http://192.168.1.100/

Other times, the device page doesnt load, and I need to use the configure_edision --wifi command. Sometimes this command works and I am able to connect to my wifi network. At other times, this error appears:

Failed to connect to non-global ctrl_ifname: (null) error: No such file or directory

Initiating connection to albright. Please wait...

Attempting to enable network access, please check 'wpa_cli status' after a minute to confirm.

Not connected. Something went wrong.

root@Edison:~# wpa_cli status

Selected interface 'wlan0'

wpa_state=INTERFACE_DISABLED

p2p_device_address=fe:db:b3:9b:80:d3

address=fc:db:b3:9b:80:d3

My router and wifi network appear to be normal as my laptop is able to use the Internet without issue. Any ideas why this might be happening?

Thanks,

Steve

Tags (3)
0 Kudos
32 Replies
Highlighted
Community Manager
39 Views

Hi Steve,

 

 

Thanks for contacting us.

 

 

I have seen some threads in the community regarding that issue and I'd suggest you to take a look at these threads since you will find useful information:
  • /message/287241# 287241 Edison Wifi does not connect: User found that the /etc/wpa_supplicant/wpa_supplicant.conf file had become corrupted so edited it.
  • /message/358437# 358437 No Wifi at startup: User was getting issues with configure_edison –wifi and solved it flashing the image 159.devkit

 

Hope you find this information useful.

 

 

Regards,

 

-Yermi A.

 

0 Kudos
Highlighted
Novice
39 Views

Hi Yermi,

Thanks for the information. In my case, I am running version 146 of the image, which is what Intel support instructed me to run in a prior thread:

I am not very familiar with WPA Supplicant, but here are the contents of my conf file:

ctrl_interface=/var/run/wpa_supplicant

ctrl_interface_group=0

config_methods=virtual_push_button virtual_display push_button keypad

update_config=1

fast_reauth=1

device_name=Edison

manufacturer=Intel

model_name=Edison

network={

ssid="albright"

key_mgmt=WPA-PSK

pairwise=CCMP TKIP

group=CCMP TKIP WEP104 WEP40

eap=TTLS PEAP TLS

psk="clobber1"

}

network={

ssid="albright"

- /etc/wpa_supplicant/wpa_supplicant.conf 1/212 0%

Does anything look to be wrong here?

0 Kudos
Highlighted
Community Manager
39 Views

Access the board through a web browser is a known issue with the latest image as Sergio mentioned in the other thread, so the image you should use for that purpose are the 146 or 159 versions, however the 159 is newer than the 146.

 

 

Regarding to the wpa_supplicant.conf file, I'd suggest you to edit the file and delete the following text:

 

 

network={

 

ssid="albright"

 

- /etc/wpa_supplicant/wpa_supplicant.conf 1/212 0%

 

 

You can edit it using the Linux editor Vi, on this site: http://www.linuxandubuntu.com/home/how-to-use-vi-editor How To Use vi Editor you can find useful information about how to use Vi.

 

 

Regards,

 

-Yermi A.

 

0 Kudos
Highlighted
Novice
39 Views

Hi,

I have edited the wpa_supplicant.conf file and ran configure_edison --wifi again. Here are the errors I am seeing:

Enter 0 to rescan for networks.

Enter 1 to exit.

Enter 2 to input a hidden network SSID.

Enter a number between 3 to 6 to choose one of the listed network SSIDs: 6

Is albright correct? [Y or N]: y

Password must be between 8 and 63 characters.

What is the network password?: ********

Initiating connection to albright. Please wait...

Attempting to enable network access, please check 'wpa_cli status' after a minute to confirm.

Not connected. Something went wrong.

root@Edison:/etc/wpa_supplicant# wpa_cli status

Selected interface 'wlan0'

wpa_state=INTERFACE_DISABLED

p2p_device_address=fe:db:b3:9b:80:d3

address=fc:db:b3:9b:80:d3

Here is the wpa_supplicant.conf file contents:

ctrl_interface=/var/run/wpa_supplicant

ctrl_interface_group=0

config_methods=virtual_push_button virtual_display push_button keypad

update_config=1

fast_reauth=1

device_name=Edison

manufacturer=Intel

model_name=Edison

network={

ssid="albright"

key_mgmt=WPA-PSK

pairwise=CCMP TKIP

group=CCMP TKIP WEP104 WEP40

eap=TTLS PEAP TLS

psk="clobber1"

}

I have not updated the Edison image yet. Do you see anything wrong with the file contents above?

0 Kudos
Highlighted
Community Manager
39 Views

Looking at your wpa_supplicant.conf file, I don't see anything wrong. In this case I'd recommend you to re-flash your Edison to the image 159, which is available to download here: http://downloadmirror.intel.com/25028/eng/edison-image-ww25.5-15.zip http://downloadmirror.intel.com/25028/eng/edison-image-ww25.5-15.zip, and the instructions to flash the Edison on this other site: https://software.intel.com/en-us/flashing-your-firmware-edison Flashing your Board.

 

 

Let me know your results.

 

 

Regards,

 

-Yermi A.

 

0 Kudos
Highlighted
Novice
39 Views

As you instructed, I reflashed my Edison to image 159. Now configure_edison --wifi command is able to connect the board to my wireless network. But I am still seeing some issues. I can view device information on edison.local in the browser of my laptop, but if I enter the ip address of the board (192.168.1.119) the connection times out in the browser. Also if I try to ping google.com through the Putty session on the board, it will time out. So does a ping from my laptop to the board.

Enter 0 to rescan for networks.

Enter 1 to exit.

Enter 2 to input a hidden network SSID.

Enter 3 to choose albright: 3

Is albright correct? [Y or N]: y

Password must be between 8 and 63 characters.

What is the network password?: ********

Initiating connection to albright. Please wait...

Attempting to enable network access, please check 'wpa_cli status' after a minute to confirm.

Done. Please connect your laptop or PC to the same network as this device and go to http://192.168.1.119 or http://edison.local in your browser.

root@edison:~# ^C

root@edison:~# ping google.com

ping: bad address 'google.com'

root@edison:~# wpa_cli status

Selected interface 'wlan0'

bssid=60:38:e0:db:29:eb

ssid=albright

id=6

mode=station

pairwise_cipher=CCMP

group_cipher=CCMP

key_mgmt=WPA2-PSK

wpa_state=COMPLETED

ip_address=192.168.1.119

p2p_device_address=fe:db:b3:9b:80:d3

address=fc:db:b3:9b:80:d3

0 Kudos
Highlighted
Community Manager
39 Views

Hi,

That is a strange behavior, it seems that it does not have internet connection, please try the following commands in a serial communication session with your board:

ifconfig usb0 down

 

ifconfig wlan0 down

 

ifconfig usb0 up

 

ifconfig wlan0 up

Additionally, you can check this other thread: /thread/96922 Wifi connection times out. You need to ensure that there is no IP conflict between wlan0 and usb0.

In case you still continue getting connectivity issues, try this alternate method to set up Wi-Fi: https://www.intel.com/content/www/us/en/support/boards-and-kits/000006202.html Connect to a Wireless Network via Linux* for Intel® Edison Boards.

Let me know if this helps.

Regards,

 

-Yermi A.
0 Kudos
Highlighted
Novice
39 Views

Hi Yermi,

Thanks for the information. The ifconfig commands did not allow me to ping google.com successfully from the Edison board. Here is the IP information for wlan0 and usb0:

root@edison:~# netstat -rn

Kernel IP routing table

Destination Gateway Genmask Flags MSS Window irtt Iface

0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0

192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0

192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 usb0

root@edison:~# route

Kernel IP routing table

Destination Gateway Genmask Flags Metric Ref Use Iface

default 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0

192.168.1.0 * 255.255.255.0 U 0 0 0 wlan0

192.168.2.0 * 255.255.255.0 U 0 0 0 usb0

Based on this, the IPs dont appear to be in conflict with each other.

I went through the alternate method of setting up a connection through Linux. Here are the results:

> > add_network

0

> set_network 0 ssid albright

FAIL

> set_network 0 ssid "albright"

OK

> set_network 0 psk "clobber1"

OK

> enable_network 0

OK

<3>CTRL-EVENT-SCAN-RESULTS

<3>WPS-AP-AVAILABLE

<3>Trying to associate with 60:38:e0:db:29:eb (SSID='albright' freq=2457 MHz)

<3>Associated with 60:38:e0:db:29:eb

<3>WPA: Key negotiation completed with 60:38:e0:db:29:eb [PTK=CCMP GTK=CCMP]

<3>CTRL-EVENT-CONNECTED - Connection to 60:38:e0:db:29:eb completed (auth) [id=0 id_str=]

quit

> > root@edison:~#

root@edison:~# ping google.com

ping: bad address 'google.com'

I cannot ping google.com or ping the board ip address from my laptop. However, I can ping this address from my laptop, which shows up as an unidentified network in network and sharing center. This address is different from the device address shown on the edison.local web page (192.168.1.119). Also, attached is a screenshot of my network connections from my laptop.

IPv4 address: 192.168.2.2

Manufacturer: Intel Corporation

Description: Intel Edison USB RNDIS Device

Driver version: 1.1.0.0

Physical address (MAC): ‎36-29-77-23-3F-07

0 Kudos
Highlighted
Community Manager
39 Views

Please double check if you are in a VPN because it can interfere with the connection, also, it may be necessary to shut off a local machine firewall just to test if it is interfering with the connection.

 

 

Regards,

 

-Yermi A.

 

0 Kudos
Highlighted
Novice
39 Views

Hi Yermi,

I have deactivated my Windows and anti-virus firewalls, and confirmed that I am not on a VPN connection (see attached images). I still cannot ping Google.com from the board. Do I maybe have to share the wifi connection with the board somehow through Windows 10 advanced sharing settings? This was an issue in the past when I did some work with Beaglebone Green boards.

Thanks,

Steve

0 Kudos
Highlighted
Community Manager
39 Views

Hi Steve,

 

 

The network connection that shows "Intel Edison USB RNDIS Device" is for connecting to the Edison using Ethernet over USB and it is a different IP address, on this site you can find more details: https://software.intel.com/en-us/connecting-to-intel-edison-board-using-ethernet-over-usb Connecting to your Board Using Ethernet over USB.

 

 

I would like to confirm the following information:

 

  • Your Edison IP address is 192.168.1.119 which is displayed next to inet addr: under wlan0. The ifconfig command display this information.
  • When your Edison has been connected successfully to "albright" and you ping google.com it fails, right?
  • When you ping 192.168.1.119 from your PC, it fails, right?
  • Which is the IP address of your PC? You can check it using ipconfig command
  • Could you please give some details regarding the connection issue you had with the Beaglebone board? It can give us some information that may help with this issue.

 

I'll be waiting for your response.

 

 

Regards,

 

-Yermi A.

 

0 Kudos
Highlighted
Novice
39 Views

  • My RNDIS adapter IPV4 is 192.168.137.1 (the same as my PC Ethernet adapter). Could this be an issue? *See attached image.
  • Your Edison IP address is 192.168.1.119 which is displayed next to inet addr: under wlan0. The ifconfig command display this information. Correct
  • When your Edison has been connected successfully to "albright" and you ping google.com it fails, right? Correct
  • When you ping 192.168.1.119 from your PC, it fails, right? Correct
  • Which is the IP address of your PC? You can check it using ipconfig command 192.168.137.1
  • Could you please give some details regarding the connection issue you had with the Beaglebone board? It can give us some information that may help with this issue. I had a similar issue where a connection could not be established from the Beaglebone board to the internet. I could not ping any web sites and npm was failing to download packages to the board. The solution was to share my laptop wifi connection with the Beaglebone board ethernet connection.
0 Kudos
Highlighted
Community Manager
39 Views

Thanks for the information. Please try modifying the content of the /etc/resolv.conf file to point to Google's DNS (8.8.8.8 and 8.8.4.4) then restarted usb0 and wlan0 and test your connection. The reserve.conf file will look like this:

 

 

root@yermi:~# cat /etc/resolv.conf

 

nameserver 8.8.8.8

 

nameserver 8.8.4.4

 

 

I have a doubt, are you using your PC as a Wi-Fi hotspot (sharing the Internet connection) and connecting your Edison to it?

 

 

Regards,

 

-Yermi A.

 

0 Kudos
Highlighted
Novice
39 Views

Some odd behavior as I try to change the contents of /etc/resolv.conf. I am able to update it using vi editor, but after issuing ifconfig commands on usb0 and wlan0, the file appears to be reverting back to its original contents (see attached image)

I am connected to my WiFi router through my laptop. The USB connections are made to the Edison board. The WiFi network adapter on my laptop is made available for sharing through Windows (see attached image)

0 Kudos
Highlighted
Community Manager
39 Views

I think the issue you are facing may be related to how you are trying to connect to the internet, could you please try to connect your Edison directly to your Wi-Fi router instead of your Wi-Fi shared by laptop? To connect to the WiFi router you can use configure_edison –wifi command as you have done before (https://software.intel.com/en-us/connecting-your-intel-edison-board-using-wifi Connecting your Board Using Wi-Fi*)

 

 

Regards,

 

-Yermi A.

 

0 Kudos
Highlighted
Novice
39 Views

Ok, I have removed the network sharing setting from my wifi adapter, and connected my Edison board directly to my wifi network. The board connects to the network, and edison.local page loads in the browser. However, http://192.168.1.119/ http://192.168.1.119/ does not load in the browser. I cannot ping google from the board or ping my board from my laptop. I used ifconfig usb0 and wlan0 up/down commands, and it still does not work.

The device info page is loading from http://192.168.2.15/ http://192.168.2.15/ in the browser, not http://192.168.1.119 http://192.168.1.119.

FYI, I recently upgraded my older router just to rule out any issues there. And I changed the IP address on the USB RNDIS device adapter to be consistent with the instructions you provided here (it is now 192.168.2.14):

https://software.intel.com/en-us/connecting-to-intel-edison-board-using-ethernet-over-usb IoT

root@edison:~# configure_edison --wifi

Configure Edison: WiFi Connection

Scanning: 1 seconds left

0 : Rescan for networks

1 : Exit WiFi Setup

2 : Manually input a hidden SSID

3 : VIDEOTRON4592

4 : albright

5 : albright_5GHz

6 : Network Gaith

Enter 0 to rescan for networks.

Enter 1 to exit.

Enter 2 to input a hidden network SSID.

Enter a number between 3 to 6 to choose one of the listed network SSIDs: 4

Is albright correct? [Y or N]: Y

Password must be between 8 and 63 characters.

What is the network password?: *******

Password must be between 8 and 63 characters.

What is the network password?: ********

Initiating connection to albright. Please wait...

Attempting to enable network access, please check 'wpa_cli status' after a minute to confirm.

Done. Please connect your laptop or PC to the same network as this device and go to http://192.168.1.119 http://192.168.1.119 or http://edison.local http://edison.local in your browser.

root@edison:~# ping google.com

ping: bad address 'google.com'

root@edison:~# ifconfig

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:65536 Metric:1

RX packets:12 errors:0 dropped:0 overruns:0 frame:0

TX packets:12 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:1080 (1.0 KiB) TX bytes:1080 (1.0 KiB)

usb0 Link encap:Ethernet HWaddr 02:00:86:b5:23:4c

inet addr:192.168.2.15 Bcast:192.168.2.255 Mask:255.255.255.0

inet6 addr: fe80::86ff:feb5:234c/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:421 errors:0 dropped:0 overruns:0 frame:0

TX packets:592 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:36567 (35.7 KiB) TX bytes:324919 (317.3 KiB)

wlan0 Link encap:Ethernet HWaddr fc:db:b3:9b:80:d3

inet addr:192.168.1.119 Bcast:192.168.1.255 Mask:255.255.255.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:63 errors:0 dropped:0 overruns:0 frame:0

TX packets:378 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:6038 (5.8 KiB) TX bytes:48629 (47.4 KiB)

0 Kudos
Highlighted
Community Manager
39 Views

Hi Steve,

 

 

It is very strange, with the Edison we can connect to the internet using a WiFi network or Ethernet over USB, depending on the way you want perform it, follow the steps below:
  1. Connecting to a WiFi network:
  • I have installed the Edison image version 159

  • Connect to my WiFi network using configure_edison --wifi
  • Edison interface configuration

  • PC interface configuration

 

  • Ping from the Edison to the PC

  • Ping from the PC to my Edison

  • Device information page

 

2. Connecting your Edison using Ethernet over USB:

 

Hope this information helps.

 

 

Regards,

 

-Yermi A.
0 Kudos
Highlighted
Novice
39 Views

I am seeing some strange information when I run ipconfig on my laptop. Hexidecimal info and no default gateway:

Edison ifconfig:

I am running version 159 of edison and can connect to my wifi network, but I cannot ping back and forth between Edison and my laptop. Also, I cannot ping any external web sites from the Edison board. I get the Bad Address response from the ping commands. I can ping web sites from the laptop however.

0 Kudos
Highlighted
Community Manager
39 Views

Have you followed these instructions: http://ssg-drd-iot.github.io/getting-started-guides/docs/connectivity/ethernet_over_usb/windows/inde... share-your-computers-wifi-connection-optional Set Up Ethernet over USB - Windows to http://ssg-drd-iot.github.io/getting-started-guides/docs/connectivity/ethernet_over_usb/windows/deta... add static IPv4 address and http://ssg-drd-iot.github.io/getting-started-guides/docs/connectivity/ethernet_over_usb/windows/deta... share your computer's WIFI connection?

 

 

Regards,

 

-Yermi A.

 

0 Kudos