Community
cancel
Showing results for 
Search instead for 
Did you mean: 
JArau
New Contributor I
1,873 Views

Edison Arduino Wifi Issues - IoT Cloud

Hi,this

While trying to send data from my Edison to the Intel Dashboard IoT Cloud, nothing is showing up in the chart data. In the serial console I get this:

2016-04-08T22:48:45.978Z - [32minfo [39m: Trying to connect to host ...

2016-04-08T22:48:46.949Z - [32minfo [39m: Connected to dashboard.us.enableiot.com

2016-04-08T22:48:46.953Z - [32minfo [39m: Environment: prod

2016-04-08T22:48:46.954Z - [32minfo [39m: Build: 0.14.5

2016-04-08T22:48:49.747Z - [32minfo [39m: Device ID set to: 02-00-86-97-7b-16

● iotkit-agent.service - iotkit-agent

Loaded: loaded (/lib/systemd/system/iotkit-agent.service; enabled)

Active: activating (auto-restart) (Result: exit-code) since Fri 2016-04-08 22:48:58 UTC; 1s ago

Process: 1425 ExecStart=/usr/bin/iotkit-agent [1;31m(code=exited, status=1/FAILURE) [0m

Main PID: 1425 (code=exited, status=1/FAILURE)

● iotkit-agent.service - iotkit-agent

Loaded: loaded (/lib/systemd/system/iotkit-agent.service; enabled)

Active: activating (auto-restart) (Result: exit-code) since Fri 2016-04-08 22:48:58 UTC; 6s ago

Process: 1425 ExecStart=/usr/bin/iotkit-agent [1;31m(code=exited, status=1/FAILURE) [0m

Main PID: 1425 (code=exited, status=1/FAILURE)

[1;32m● [0m iotkit-agent.service - iotkit-agent

Loaded: loaded (/lib/systemd/system/iotkit-agent.service; enabled)

Active: [1;32mactive (running) [0m since Fri 2016-04-08 22:49:08 UTC; 1s ago

Main PID: 1436 (node)

CGroup: /system.slice/iotkit-agent.service

└─1436 node /usr/bin/iotkit-agent

Registering components

It looks, that there is a issue with the connection since the status is FAILURE.

I am not sure what could be the reason for this.

8 Replies
idata
Community Manager
127 Views

Hi Jean,

 

 

Which is the result of running the following commands:

 

uname –a systemclt status iotkit-agent

 

 

Did you set a password, name and WiFi connection for the board using configure_edion --setup?

 

Does the board have Internet connection? Please post a screenshot of running ifconfig and ping www.google.com –c3

 

Are you following the instructions from: https://software.intel.com/en-us/intel-iot-platforms-getting-started-cloud-analytics https://software.intel.com/en-us/intel-iot-platforms-getting-started-cloud-analytics

 

 

Regards,

 

Charlie
JArau
New Contributor I
127 Views

Hi,Yes I have use the started guide from the cloud, I have set it up, and is connected to the same wifi of my laptop. When I start it for the first time, I could see the data on the Iot, but after I flashed to the latest version I started to experience some errors.. I tried all the codes you mentioned, everything looks fine except the iotkit-agent status which give me the code=existed, status=1/FAILURE

idata
Community Manager
127 Views

Hi Jeanfranco,

 

 

In order to be able to run the service successfully I suggest you to run:

 

systemctl stop iotkit-agent systemctl disable iotkit-agent reboot systemctl start iotkit-agent systemctl enable iotkit-agent reboot

 

 

After this, check the status of the service. If this doesn't work I suggest you to update the service and image you are using, I saw that the image you are using is from Jun 19 2015, the latest one is from Mar 14 2016. [https://software.intel.com/en-us/iot/hardware/edison/downloads https://software.intel.com/en-us/iot/hardware/edison/downloads] Check the output of running uname –a on this image:

 

Linux jarvis3.0 3.10.17-poky-edison+ # 2 SMP PREEMPT Mon Mar 14 15:26:16 PDT 2016 i686 GNU/Linux

 

I'm guessing that the service could be old too, run the command opkg list-installed | grep agent, I'm using the 1.7.0–r0 version.

 

 

Regards,

 

Charlie

 

JArau
New Contributor I
127 Views

Hi Charlie,

I have flashed with the new version, and did the reboot with and without the agent disabled. My issue persist what I found strange is that every time I run the systemclt status iotkit-aget it appears as it is running, but then I do it again it get the FAILURE code, then again the FAILURE, then again is running. Is this normal? I am a little confuse about this every time I run the status it looks like it is changing, I am attaching a picture of it. I am still not able to send data. (Nothing is being show in the IoT CLoud DAshboard)

What does it means : Hint: Some lines were ellipsized, use -l to show in full?

idata
Community Manager
127 Views

Hi,

 

 

The –l parameter will show more information in the debug message. Please run systemctl status iotkit-agent –l and uname –a (just to verify that the board has indeed the latest image) and show us a screenshot of it. Please use the flashall script to re-flash the board. https://communities.intel.com/docs/DOC-25154 https://communities.intel.com/docs/DOC-25154

 

 

You are flashing the board with a fresh image and just checking the status of the service is this right? Or are you changing some other service?

 

Are you using configure_edison --setup to configure your board?

 

 

Regards,

 

Charlie

 

JArau
New Contributor I
127 Views

Hi Charlie, here is an image of the two commands you told me to use:

I have not use the setup configuration (I did set up the wifi -edison is connected to the same wifi as my laptop-)I am not changing any services, just re-flashing with a new image. the Yocto 3.0.

Issue persist

idata
Community Manager
127 Views

Hi,

I re-flashed my edison and I was able to have the same output you were having. I noticed that this happened to me while the board was being powered by the USB port and having already registered my device in the Dashboard.

 

I did the following, I powered the board with a power supply, delete the device on the Dashboard and re-flashed the board, then I ran the following commands:

 

configure_edison --setup

 

date -s "2016-04-14 17:30:00"

 

iotkit-admin systemctl stop iotkit-agent iotkit-admin test

 

iotkit-admin activate xxxxxxxxx

 

systemctl stop iotkit-agent systemctl start iotkit-agent systemctl disable iotkit-agent systemctl enable iotkit-agent

I hope this works for you, now if I run systemctl status iotkit-agent I get:

After this, I reboot the board and I'm not having the issue anymore

Regards,

 

Charlie

 

JArau
New Contributor I
127 Views

Hi Charlie,

I fixed the issue, what I did was removing the device from the cloud analytics and adding it again. Also, I type killall node in the root to kill all background programs that were using the address port and did not let iotkit-agent update. Now it works perfectly.

Thank you for all your feedbacks

Jeanfranco

Reply