Community
cancel
Showing results for 
Search instead for 
Did you mean: 
mfu1
New Contributor I
1,947 Views

Edison Image build,OpenSSL error,SSLv3 handshake failure

Jump to solution

Hi:

I am building my Edison image,but bitbake can not fetch this:

WARNING: Failed to fetch URL http://download.xdk.intel.com/iot/xdk-daemon-0.0.35.tar.bz2 http://download.xdk.intel.com/iot/xdk-daemon-0.0.35.tar.bz2, attempting MIRRORS if available

ERROR: Fetcher failure: Fetch command failed with exit code 4, output:

OpenSSL: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

Unable to establish SSL connection.

ERROR: Function failed: Fetcher failure for URL: 'http://download.xdk.intel.com/iot/xdk-daemon-0.0.35.tar.bz2 http://download.xdk.intel.com/iot/xdk-daemon-0.0.35.tar.bz2'. Unable to fetch URL from any source.

From China mainland,intel website is not blocked by the Great Fire Wall. :-)

I can get the target files by firefox normally.

OS: Ubuntu 12.04

OpenSSL version:

OpenSSL 1.0.1 14 Mar 2012

I doubted that original openssl version was too old which has heartbleed bug ,so I upgraded openssl to 1.0.1s,but this problem is not fixed.

Anybody has solution?

Thanks a lot!

1 Solution
mfu1
New Contributor I
240 Views

Finally,the compile process finished.

Two points need to pay attention:

1.Ubuntu 12.0 is incompatible with intel.com.

2.Must solve the Paho-MQTT problem.

Thanks all for your warm heart.

View solution in original post

13 Replies
idata
Community Manager
240 Views

Hi,

 

 

Up to what step of the BSP were you able to complete? The recommended BSP to build the Edison image is http://www.intel.com/content/dam/support/us/en/documents/edison/sb/edisonbsp_ug_331188007.pdf http://www.intel.com/content/dam/support/us/en/documents/edison/sb/edisonbsp_ug_331188007.pdf .

 

 

What bitbake command have you used, what section of the BSP were you following?

 

 

Sergio

 

mfu1
New Contributor I
240 Views
idata
Community Manager
240 Views

Based on your "SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure" error I'd say there's an ssl version incompatibility. I found online two suggestions that might help you. Both are described in this link http://serverfault.com/questions/560053/curl-succeeds-on-an-https-request-wget-does-not http://serverfault.com/questions/560053/curl-succeeds-on-an-https-request-wget-does-not . The suggestions are to use the --no-check-certificate option and the --secure-protocol=sslv3 option with the wget command.

 

 

Give it a try and let me know your results.

 

 

Sergio

 

mfu1
New Contributor I
240 Views

Hi:

Thanks for your suggestion.

I followed your method, but the problem is not fixed.

like this:

openssl version

 

wget --secure-protocol=sslv3 (and same as using auto,tlsv1)

wget --no-check-certificate

I feel very sad with that result.

idata
Community Manager
240 Views

It seems you're able to download the file from our website with Ubuntu 14. Seems to be an issue related to Ubuntu 12 and the SSL version. Try using Ubuntu 14 and let us know if you still see this behavior.

 

 

Sergio

 

YMeng3
Novice
240 Views

Hello there:

I have exactly the same question, and I`m from China mainland, too. By simply clicking the http://download.xdk.intel.com/iot/xdk-daemon-0.0.35.tar.bz2 http://download.xdk.intel.com/iot/xdk-daemon-0.0.35.tar.bz2 I can download the file, but I don`t know what to do next. By the way, I try the same code

wget --secure-protocol=sslv3

wget --no-check-certificate

and also shows"Unable to establish SSL connection.

Tell me how is it going now and what are you going to do ?

mfu1
New Contributor I
240 Views

By using Ubuntu 12.04,whatever the OpenSSL version was,from 1.0.1d to 1.0.2, wget connection will always be refused by intel.com with SSL error.

So now, I am using Ubuntu 14.04 32bit for Edison image compiling.

Wget files from intel.com in Ubuntu 14.04 had been tested.

Compiling seems ok since then.

呵呵,我们被arduino社区的帖子误导了。

reference:

https://software.intel.com/zh-cn/articles/how-to-run-yocto-linux-os-in-a-virtual-machine https://software.intel.com/zh-cn/articles/how-to-run-yocto-linux-os-in-a-virtual-machine

http://www.intel.com/content/dam/support/us/en/documents/edison/sb/edisonbsp_ug_331188007.pdf http://www.intel.com/content/dam/support/us/en/documents/edison/sb/edisonbsp_ug_331188007.pdf

YMeng3
Novice
240 Views

Cool, please tell me when you succeed in compling the edison image~

idata
Community Manager
240 Views

Were you able to perform the test we recommended using Ubuntu 14? What were your results?

 

 

Sergio

 

mfu1
New Contributor I
240 Views

Hi:

The compile process still failed like this:

I found that the file: 'org.eclipse.paho.mqtt.c.git' did not exist in eclipse official website, and the git library has changed.

The URL:http://git.eclipse.org/gitroot/paho http://git.eclipse.org/gitroot/paho was not here.

 

So I read this http://www.intel.com/content/dam/support/us/en/documents/edison/sb/edisonbsp_ug_331188007.pdf http://www.intel.com/content/dam/support/us/en/documents/edison/sb/edisonbsp_ug_331188007.pdf again,and want the compile process DO NOT download this file with comment org.eclipse.paho.matt.c.git download in edison_image.bb like this:

and rebuild image.

BUT the process still failed,the building process still git matt package......:-(

Give it up or retry?

TMalh
Novice
240 Views

Hi,

to solve the Paho-MQTT problem, see this thread:

In short, edit the file ~/edison-src/out/linux64/poky/meta-intel-iot-middleware/recipes-connectivity/paho-mqtt/paho-mqtt_3.1.bb

In the line SRC_URI do:

SRC_URI = "git://github.com/eclipse/paho.mqtt.c.git;protocol=http \

file://makefile.patch \

"

Best,

Tiago

idata
Community Manager
240 Views

Related to .

mfu1
New Contributor I
241 Views

Finally,the compile process finished.

Two points need to pay attention:

1.Ubuntu 12.0 is incompatible with intel.com.

2.Must solve the Paho-MQTT problem.

Thanks all for your warm heart.

View solution in original post

Reply